Android app not connecting to Rock NUC first time

I have looked through the forum and couldn’t spot a similar entry, if I have missed it then feel free to question my searching ability.

I pick up my Motorola G4+ running Android 7, select the Roon app and it can’t find the Rock NUC. I manually enter in the IP and it still doesn’t find it, use the option to control the Roon device and it hooks up to the player fine. If I reboot the Roon, it connects, also if I turn wifi off/on on the phone, that connects as well.

At the moment I am connected fine, and if I shut down the app and run it again, it connects straight away.

Is there a setting that I have missed?

Also, could the last Roon device used be cached in the app?

Thanks - Terry

Long thread:

It appears to be a subtle, difficult to replicate interaction between (some) Android devices, network hardware, Roon device discovery, and Linux network stacks (Rock is Linux-based). Turning off IGMP snooping on your home network, if that is possible with your setup, might help.

I’m in the same boat. It seems the support people have tried hard to figure out why it happens to some people with the ROCK/Android combination, but gotten nowhere. The best workaround I’ve found is hitting “save” on the ROCK home page. This resets the connection the same way that restarting Roon does. However, it’s less disruptive because the music doesn’t have to stop playing.

Same issue here. I’ve been rebooting my Samsung Android tablet to get around the issue. Pretty frustrating tbh :frowning:

I am “glad” that it isn’t just me then. It isn’t the end of the world, but it would be nice to get back to seamless connections.


That works for me - thanks John.

No worries.