Android app SwiftKey keyboard disappears

Hi guys:

There has been some discussion re the above, one thread no joy, one, tablet reboot worked.

Rebooted. No joy. Keyboard works with all other apps.

Samsung Galaxy S8. Using SwiftKey keyboard.

Any help, much appreciated. Pretty hard to use Roon in my reviews without the search function. Thx.

Hi Anthony,

I’m using a Galaxy S8+ with Roon and SwiftKey and had the same extremely irritating problem.

The solution is to turn off “Full Screen” mode for Roon, leaving the Navigation Bar visible at the bottom of the screen. Irritating, but much better than not being able to type a search term.

You can do that by swiping up from the bottom of the screen and double tapping the small circle on the left of the Navigation Bar.

I’m not sure whether the disappearing keyboard problem lies with Samsung, SwiftKey, or Roon. I believe some apps have to be coded to properly handle the unusual aspect ratio of the Galaxy S8 series in full screen mode. It would certainly be great if the Roon guys can fix this in a future update.

Hope that helps,


1 Like

Thx Cameron. Will give it a try. cheers, a

Eh, voila! Parfait. Thx :slight_smile:

Hi @Anthony_Kershaw and @Cameron_Fletcher ----- Thank you for the feedback and sharing your observations with us. The insight is always appreciated!

Moving forward, our techs are going to be looking into this behavior to see if can reproduce in house. In light of this, may I very kindly ask you both to please provide me with the following:

  • A description of the device hosting your Roon core.

  • The android version currently installed on the mentioned remote devices.


Hi @Eric,

Thanks for looking into this.

My Roon Core is hosted on a general use (i.e. not dedicated just to Roon) custom built Windows 10 PC, built around the following components:

Motherboard: ASUS Z170­AR Motheboard
Processor: Intel Core i7 6700K Quad Core LGA 1151 4GHz Unlocked CPU
Memory: Corsair 64GB (4x16GB) CMK32GX4M2A2400C14 DDR4 2400MHz
Graphics: Gigabyte GeForce GTX 1070 G1 Gaming 8GB Video Card
Drive 1 (OS): Samsung 960 Pro Series 2TB M.2 SSD
Drive 2: Samsung 850 EVO 2TB SATAIII SSD Solid State Drive
Drive 3: Samsung 850 EVO 1TB SATAIII SSD Solid State Drive
Drive 4: Western Digital Red WD80EFZX 8TB 3.5" NAS Hard Drive
Drive 5: Western Digital Red WD80EFZX 8TB 3.5" NAS Hard Drive
Power Supply: eVGA 220­G2­0750­XR 750W G2 80+ Gold Full Modular Power Supply
OS: Microsoft Windows 10 Pro 64bit (currently on Version 1703, Build 15063.674)

My android device is a Samsung Galaxy S8+ on the Australian Telstra network, up to date with all over-the-air system updates provided on this carrier, with the following details:

Model number: SM-G955F
Android version: 7.0
Baseband version: G955FXXU1AQH3
Kernel version: 4.4.13-12050265
Build Number: NRD90M.G955FXXU1AQH3

Day to day I’m using an up-to-date version of SwiftKey Beta Keyboard version, which exhibits the problem described. However I just switched to an up-to-date version of SwiftKey Keyboard (i.e. the non-beta version), and the problem is identical. I also tried using the default Samsung Keyboard that comes with the phone, and the problem was the same.

I should also note that on my system this problem is not intermittent - it happens deterministically every time the Roon app is opened and the “Navigation bar” is set to auto-hide using the Samsung Galaxy S8/S8+ “Show and hide button” on the navigation bar. On my phone this setting can be found at Settings > Display > Navigation bar > Show and hide button. It can be enabled by switching on that toggle, which adds a small dot to the left side of the soft navigation bar. Double tapping that dot when the Navigation Bar is showing on the screen will lock or unlock the Navigation Bar. When it is unlocked, it will slide down to disappear after a few seconds of not being used, like the old “auto-hide task bar feature on Windows”. This makes the foreground app take up the full screen on the Galaxy S8/S8+. You get the Navigation bar back by swiping up from the very bottom of the screen.

If the navigation bar is currently set to auto-hide, and you touch the “Search” text box in Roon, you see the SwitfKey keyboard slide up from the bottom of the screen for a second, flash, and then immediately disappear before you can use it. At this point, if you swipe up from the bottom of the screen to show the Navigation bar, then double tap the small circle on the left to lock it to “always show”, then hit the Roon search box again, the Swiftkey keyboard appears, stays visible, and can be used to enter a search term, as normal.

Hope that helps.



Hi @Cameron_Fletcher ----- Thank you for the very detailed follow up!

Moving forward, I am going to be passing this information over to our QA techs for internal testing. Once my report is updated and passed back, I will be sure to update this thread accordingly. Your patience is very appreciated!


Thanks Cameron, sorted Mrs M’s Galaxy 8 :slight_smile:

To add a bit of info here, Samsung makes it very easy to accidentally initiate full screen mode on the Note 8 and S8+ but involved to reset the app to disallow full screen mode. Once it’s in full screen, any activity that requires an on screen keyboard such as search breaks. As OP said, the keyboard will flash open then close immediately. If a screen cap is helpful, I’ll send one along.

My Samsung Note 8 does this too, very annoying, I’ll try to disable full-screen mode.

All ---- Thank you very much for the continued feedback here, the insight has been very appreciated!

I raised this report with our tech team yesterday and have opened a ticket in our system to track this behavior. As per my conversation with our techs, in order to properly understand this behavior we will require the following information:

  • The make/model of the device having the issue
  • Which Android version the affected device is running.
  • What type of keyboard is being used on the device (i.e stock keyboard, Swiftkey, etc)

Looking forward to your responses!

PS - Cameron, I have all of your information recorded already, thanks again!

A post was split to a new topic: SwiftKey keyboard disappears