Android Roon Remote can't connect to core after latest update

Hi Dylan,
I already tried rebooting/disconnecting the core, remote and reinstalling the app on the phone, i probably should have mentioned that. Before the latest update, the remote was working. After the update to 521, it stopped working. Even after i updated the android app, it still can’t connect to the core.

Thanks for confirming, @Otanes.

You mentioned that this is happening with multiple Android devices — Do you have any iOS, Mac, or Windows devices you can try using as a test? It would be helpful in understanding where the issue is stemming from to know if this is happening for all remotes or if it’s just Android specific.

Alright, I just borrowed my mother’s Ipad pro, it seems to work fine as a remote.It might just be an android issue. I know that you guys are facing a lot of support requests and are trying your best to resolve this issue. Thanks

Thanks for the info, @Otanes. Our team is actively working on this issue and we will be sure to update you as soon as we have more information. Your patience is much appreciated!

Mine too…
Phone: Motorola G3
Android Ver 6.01
Core: Roon Rock Version 1.7 (build 521) stable

Roon App freezes after the last update. Restarted Rock, restarted phone, de-installed Roon App, installed Roon App, nothing has changed. It freezes immediately, I can’t do anything… It doesn’t really matter since I only use this smartphone to control the ghettblaster in the shower. But it would be nice if it works again sometime.

Same problem.

Android 8.1.0 on Lenovo TAB.

The freeze is at displaying the new releases cover art.

App freeze after connect to core The freeze is at displaying the new releases cover art… Moto E4 Plus, Android 7.1.1, patch level June 1 2019, build NPRS26.58-45-26

Reinstalled core and remote app on phone. No help.

Same here. Samsung tablet.
Android 7.1.1

Hi everyone,

We’ve posted our latest update on this issue here:

Hi…having the same issue with S9 with Android 9… and Galaxy Tab A.
Appreciate your efforts. The remote functionality on my devices is of great importance. Without this functionality, there is no way for me at my home system to control anything about my system, rendering roon useless.
Do you know if there is already a solution for these issues?


We’ve released a new update, Roon 1.7 Build 528, which contains improvements that we believe will help with the issues you are experiencing here. Please see our release notes below:

The Team At Roon Labs

OK. It functions again. :+1:

With my old little device better than ever :+1:

Hi Dylan, my issue is still not resolved even after installing the updates. I even tried reinstalling on my android, it can serve as an endpoint but not as a remote

A post was merged into an existing topic: Not able to connect Roon Core after Roon remote is updated to build 528

Hi @Otanes,

If you toggle Accept connections from remotes off and back on is there any change?

Can you confirm what kind of Netgear router is in use? Is any other networking gear being used?

Nope, no change after toggling. The same failed connection. I use a netgear nighthawk x6 r8000 router that is linked to the core PC with ethernet.

Just thought I’d add to this. I’m running core on windows 10. Using my android phone as a remote (pixel 3A). I can connect to the core if I toggle the “Accept connections from remotes” off then back on. After my phone is idle for a bit and locks out, when I open my phone again it can’t connect. Restarting the app (force stop) or restarting my phone doesn’t fix it. The problem doesn’t seem to be with the android app but rather with the core… Hope that helps.

Edit: nevermind, per other threads, setting the ip of the core server seems to resolve the issue.

A post was split to a new topic: Toggling “Accept connections from remote” to connect android phone

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.