Android Roon Remote on Chromebook not connecting


I’m using Roon Version 1.3 (build 262) with ROCK on a NUC 7i5 and Android Roon Remote running on an ASUS C300S Chromebook.

As you probably know, the Chrome OS now officially runs Android apps.
I"ve downloaded the Roon Remote app, and though it runs, it does not discover my Roon Core.
The same app, running on my Android phone, does discover the core.
Clicking the “Why can’t I see my remote libraries” link and adding the ROCK’s ip address only yields a message I haven’t entered a valid IP address, although I’ve entered the same one that appears for the ROCK under “Settings/General” in the Roon app on my phone.
My devices are on the same LAN and none has a firewall.

My music is stored on a Synology NAS connected by Ethernet.
My collection size is 7829 tracks.

Hi @John_Webb ---- Thank you for the report and sharing your feedback with us. Both are very appreciated!

Moving forward, can you please verify that there are no active firewalls or antivirus applications running on the Asus C300s Chromebook. If there are, would you kindly disable these functions (temporarily of course) and confirm if this action triggers a change in behavior with the mentioned device.


Hi Eric -
I’m sure there’s no antivirus running. A little extra research has shown me Chromebooks have a firewall that users can’t modify unless they use “developer mode.” So there’s a firewall running that I currently have no control over. I guess this begs the question of whether I need to learn to how use ‘developer mode’ and open ports in the Chromebook firewall. (Sigh.)

Roon used to work on Chromebooks via Android but it stopped working a few months ago. I keep hoping that Chrome OS updates will fix this but it hasn’t so far.

There’s a long thread on Android Roon Remote problems, still unresolved. With a variety of Android devices, but seems to depend also on still unidentified particulars of the rest of the setup.

1 Like

Thanks for passing that on. The phone app gives me a bit of grief too so I’ll have a look.

Hi @John_Webb ---- Thank you for following up with me and providing the requested feedback. Both are very appreciated and sorry to hear of the continued troubles.

Moving forward, as Fernando has pointed out we currently looking into reports of connectivity issue between Android based remotes and Linux based core machines. During our evaluation of this issue, we have found that the following tests have produced some positive results for users experiencing this behavior. May I kindly ask you to please give the following a shot and let me know what the results are?

TEST #1:

  1. Shut down your Core
  2. Open Roon on your Remote
    (Tip: If you are using a phone, make sure you keep it awake)
  3. Roon should be on the “Searching For Core” screen
  4. Start up the Core

TEST #2:

  1. Start up your Core
  2. Open Roon on your Remote
    (Tip: If you are using a phone, make sure you keep it awake)
  3. Kill the Roon app
    Tip: If you are using Android please go to Settings > Apps > Roon > Force Stop
  4. Restart Roon on on your Remote

Lastly, in an attempt to gain a better understanding of what could be causing this issue we have asked our users to please fill out the survey found here in Mike’s post.


Hi Eric -
Sorry I didn’t answer for so long. I got used to restarting my Core so I could connect with my Chromebook. But now I have to do the same thing with my Android phone as well. I’ve finally completed the survey, as you asked last September. When I do test #1, both of my devices connect to the Core. When I do test #2, they don’t.

@Eric - I have an update to my last message. After reading the more recent posts in the “Android app having trouble finding Linux Core” discussion, I followed the suggestion to switch my Android phone to Airplane Mode then connected by wifi only. It found the Core, even after I killed the app and opened it again. So, please make of that what you will.

Hi @John_Webb ---- Thank you for the follow up and no apologies necessary, I greatly appreciate the update/insight.

I wanted to check in with you and see how the remote has been holding up since your last. Let me know :sunglasses:


Hi @Eric, thanks for checking in. My Android phone remote worked reasonably well after that last post, although it would sometimes take a few seconds to locate my Core. Today it had stopped connecting altogether so I tried the Airplane mode trick again, to no avail this time.
But it turns out there is another trick, with which I am having more success. I read, in the thread Fernando referred to above, that one user goes to the home page of his ROCK when his remote won’t connect, and in the Wireless section, he simply presses the Save button. I do almost the same thing, but with the Save button in the Ethernet section (because I use an Ethernet connection on my ROCK computer.) This has worked for me every time I try it, which is about 3 times in the last week or so. It worked after the Airplane mode trick didn’t today. It’s handy because it doesn’t require stopping the music. My remote consistently starts seeing the Core again about 5-10 seconds after I press the Save button in the Ethernet settings on the ROCK. I should mention the Save button trick also works when Roon Remote on my Chromebook is having trouble connecting.
It’s a peculiar workaround, but I hope sharing this helps somehow.
PS I noticed I misidentified my ROCK computer as an Intel NUC 7i5 in my original post. It’s a 5i5.

My pleasure @John_Webb, I appreciate the update and feedback!

I would like to enable diagnostics on your system so we can have a closer at look into what is occurring just before the remote disconnects and what happens after you use the mentioned work around. With this in mind may I very kindly ask you for the following:

  • Please reproduce the issue and note the time when the remote is unable to connect to your Roon core.
  • Please note the time when you perform your work around (i.e “…I press the Save button in the Ethernet settings on the ROCK”) and the remote is once again able to connect to the core.

Once I have the above time frames I will go ahead and enable the mentioned diagnostics on your account, many thanks!


Hi @Eric. I did it twice.
I opened the app at approximately 17:03:40 MST today (March 26, 2018), and it was “waiting for the Remote Core.”
At 17:04:00 I hit “Save”
At 17:04:15 the Remote found the Core.
I closed the app and repeated the same process ten minutes later.
When I opened the app at approximately 17:14:30. it was waiting for the Core.
At 17:14:45 I hit “Save”
At 17:14:59 the app connected to the Core.
Have I gathered the times correctly?

Hi @John_Webb ---- Thank you! This is exactly what I was looking for :+1:

Now that I have the requested time frames I am going to be enabling the mentioned diagnostics. What this action will do is the next time the application is active on your core and the remote where the test was conducted a diagnostics report containing a set of your Roon logs will automatically be generated/uploaded to our serves directly.

I will touch base when the report comes in so you know we have it, thanks again John!


Hi @eric I thought I’d check in. I’ve gone through the steps to reset my Android remote a few times since we last spoke. I wondered if you’d captured data successfully.

Hi @John_Webb ---- Thank you for follow up with me and my sincerest apologies for the slow response on my end.

Yes, the diagnostics report had been received and our techs had a chance to review the attached logs. The team noted they could see the “disconnecting” behavior in the traces but they were in conclusive in the sense that there was nothing pointing to the cause of the behavior.

I then passed my report over to one of our senior developers to get his thought on the observation you had made when hitting “save” button in the networking section of ROCK’s web UI. He had mentioned that this action is essentially doing the same thing as when a core is rebooted as it is refreshing the connection between the core/remote. That’s why you are noticing that your remote is being brought out of the state it is in and thus able to connect.


This may be of interest @eric: as suggested by @Fernando_Pereira I switched off IGMP snooping on my router last week, and Roon on my Android phone has been working normally since. Roon on my Chromebook still can’t find the core, but it’s progress!

You switched IGMP snooping on? My experience is that I needed to switch it off.

Nope, I switched it off too.