Android USB DAC only plays at 16/44.1 [Ticket in]

Mike been testing it tonight with my FIIO KA2 and it seems to convert everything to 16 bit (but still works nicely and sounds great)

Is this the expected result?

I doubt it the DAC supports 24bit so Roon should output that to it and not be downsampling.

FiiO KA1 with iPhone 13 Pro Max…

Do you have Roon ARC set on “Original Format?” Your DAC supports 32/384 and DSD256.


1 Like

What build/platforms are you running on Core and ARC?

Iim pretty sure that it does, but it would be great to know options available as a lot of users are going to be scratching their heads

Both new EA platforms
ARC biild81 (with USB option)
Core build 1159

All working besides down sampling to 16 bit

Do you have Roon ARC set for “Original Format” for both WIFI and cellular?

Thanks Jim yes and as. You can see ARC is doing the down sampling

I even tried changing mobile playback to original.

Are you sure your phone’s WIFI is turned on and connected to your network?

Yes Jim (I won’t say I do this for a living as we all do stupid things from time to time)

Buti can only track it down to being the USB DRIVER on Android for the KA2 for the moment.

TBH I am fine with 16/44 I just figure Roon need information.

OK. I thought maybe you were trying to figure it out and I was trying to help you. Never mind then.

1 Like

I would change cellular to original as well to rule out if Arc is doing something silly and using cellular over Wi-Fi. Stranger things have happened.

1 Like

@Michael_Harris not sure if it affects it, what’s your core set to under services and your chosen streaming service. Is it CD quality?

Have you tried this with local media of a higher quality?

It was, and I switched it back before going to bed as I had a long drive today and didn’t want to use al my data :wink:

Hey Jim sorry if I came across short, that was not my intention I quickly replied before getting in the car early this morning just after waking up :wink:
Your suggestions is always appreciated :+1:

Hi Lewis this is streaming from my local library and it is being down sampled by Roon before being sent to the DAC.
That’s why I thought it was worth sharing this, to understand if this is expected action.

Might be the early release is throttled to 16/44.1 as default.

But with @mike asking what versions you’re on does suggest it should be doing this.

I couldn’t see, but have you tried offline content? Is it the same.

All content seemed to be the same.
Though I am away for a couple of days now so maybe I will check for some 24/96 content and play it.
It’s not a complaint more trying to understand early on what is the expected behaviour.

I run through a veriaty of tests and all ended up with the same results. Could be an Android issue or an Android issue on certain phones. I can try my Pixel later and see how that does

I’m on android and not having this problem, although I have both quality settings (WiFi and streaming) set to original quality.

1 Like