Another network problem [Resolved - Rolled back automated WIN updated]

Hi crew. I run my Roon Server on an i7 server with Windows 2012R2 and AO. For maintenance, I took the server out of minimal core mode back to GUI to update Windows and JRiver, which also runs on the server. After reboot, no Roon endpoints, including SONOS boxes, are discoverable. The telltale to me is that the SONOS boxes always appear in the network list of Playing Now in JRiver – and they are missing from there. Everything is plugged into an unmanaged switch, which seems to be functioning. I have rebooted the switch, the server and the router multiple times. I just can’t figure out why it was working before reboot and now isn’t. I’m in GUI mode now just for testing. Thoughts on what I am missing here? SONOS boxes are all online in the SONOS app. Feels like something DLNA related. JCR

Did you have any AV or Firewalls on the Server?
Did the enable after after a reboot?

Not that I see.

Well, Roon does not use DLNA so you can discard that.
Did anything networking change?
Gateway? IP? Route? Subnet?
Is the cable good?

Is DNS working? Can the roon server reach out to the internet?
Have you look at the Roon logs or events?

I don’t know where to find Roon logs or determine if Roon is seeing the internet. I certainly can get Roon to load up and run on the server, but since not even a Ethernet hard wired PC connected via my switch can connect to Roon, I don’t know how to evaluate. (That PC is seeing the internet, so the router is passing internet connectivity on.). Perhaps you can share how I find the log files and what I would be looking for.

Same gateway, same IP address, same route, same subnet. But I can’t access JRiver remotely through JRemote either, and I’m sure the Roon issue is related to the same. I’ve not switched cables but I can’t see why it would suddenly go bad.

It’s perplexing me, for sure. JCR

Update: the router advanced setting page (an Orbi mesh network router) is reporting an IP subnet mask of I’ve never seen 254 in the mix before and wonder if that is my problem right there. When I go into LAN setup, it shows as the IP subnet for my main router IP address of I see this discrepancy now but don’t know how to fix. I did do a renew of the IP address in the advanced page and it stayed at How say you that I deal with this?

Further update. Netgear support says that the 254 network is Comcast’s not mine. The only thing Netgear had me do is open NAT Filtering (instead of just Secured) and disable SIP ALG. (Sounds like a disease.) When I go into my switch, for example, at, it shows me that it is, properly, on subnet with the correct gateway of So, I don’t think a wrong subnet is the answer.

Another update. I am remoting into a home PC, so we know the internet is working. I can access my RPi3 devices through Putty and am in fact updating them to the latest DietPi v149. So this tells me that wifi is working around the house. All the SONOS boxes appear in the device list in the router. But I can’t get Roon core to connect to anything, nor JRiver.

Hi @Jeffrey_Robbins ---- Can you verify what IP address is being assigned to the i7 hosting Roon Server and the subnet being listed as well?


@Eric, the IP config is as it should be. Subnet Default gateway

Yet, Roon core AND JRiver on this server aren’t seen outside of the server. I am clueless. JCR

Just to rule out firewall issues have you checked here and to test turned off any/all firewall(s) Control Panel\System and Security\Windows Firewall

Actually, I can’t turn the firewall on or off. When I go to the turn Windows firewall on or off tab, I have a notice with a red border on the left to update my firewall settings. It says I’m not using the recommended settings.

Wonder if I should and then turn off. But, it doesn’t appear to be on. JCR

Maybe you should update your settings…???

Actually, none of the Windows firewall settings or tabs work. I can’t go to “recommended settings” aka default or turn the firewall on or off. But, it was this way before I rebooted the server and Roon worked fine. Yes, it would appear my firewall is corrupted. But this has not impacted Roon in the past, so I bet not now. Not sure what next to try, though. JCR

Hi @Jeffrey_Robbins ----- Thank you for the report and sharing your feedback with us. Both are appreciated.

My understanding of Windows 2012R2 is that there are other settings outside of the firewall that can affect network access. Doing a quick google search I came across the following article on how to disable the IE Enhanced Security settings.

Moving forward, may I kindly ask you to please give the highlighted procedure in the article a go and once you’ve completed it please make sure the firewall is either turned completely off OR that the correct settings are in place for Roon/RAATServer.


I am also having problems installing Roon on a new box with Windows 2012 R2. I have been running Roon on a HTPC with no problems - I installed 64 bit versions of the server version on this new box and installed Roon Bridge on the HTPC

both programs install fine but when I launch them neither one will do anything - they are both running as shown in the task bar and in task manager.

I went through your Enhanced Security settings and used those - no luck

what else can I try?

Both RoonServer and RoonBridge have no UI for control. To access and control them you need to load Roon up on another pc or a tablet or phone.

Thank - you Daniel ! - that was the solution

I did load Roon back onto the HTPC and pointed it to the files on the new server and all is good

however I’m not following why I had to add both Roon Server and Bridge software???

Previously Roon was installed on a HTPC and pointed to a NAS that was attached to my old server - I didnt install those before… what are your Server and bridge software doing?

Hi @Eric. I shut off the IE Enhanced Security and rebooted the server. No luck on either Roon or on JRiver. JCR

@Eric, I’ve run Fing on my iPhone and here are the results (screenshots below):

  1. I can ping the RPi3 Roon endpoints, so they are connecting to the network.

  2. The sonicTransporter is ethernet connected to my switch, which is ethernet connected to the Orbi router. I can ping the sonicTransporter.

  3. The Bel Canto renderer is also Ethernet connected to the switch and I can ping that.

  4. The Netgear switch is seen here.

  5. The failure is in reaching either of the PCs that are Ethernet connected to the switch. Complete packet loss on both. The CAPSZUMA is my Roon core and JRiver server. The Dell is a PC on the other side of the room downstairs that runs Roon for access.

  6. Both PCs are getting correct IP addresses and are on the same subnet. I can connect to the internet with both PCs.

To be clear again, JRiver on the CAPS server is seeing the Bel Canto renderer (but NOT the openhome version, which, although I no longer use it, the sonicTransporter is seeing) but is not seeing any of the SONOS boxes, which it did before. The CAPS server never saw the Roon RPi3 endpoints in JRiver so that they aren’t there now means nothing to this problem.

Hopes this provides some more help. JCR

RoonServer is a version of Roon which is not graphical and autostarts with a reboot. Roon bridge is just the network endpoint component. Both auto load on start up of OS and are meant to function on headless machines.

So in your case, you would be running RoonServer on the Win2012 machine and running Roon on the HTPC. When setting up Roon on the HTPC you would select the Win2012 as the core and just be running as a client on the HTPC.

Yes, that is what I do – or should say, did. JCR

@Eric – update. Fixed! One of the Windows KB updates shut down the server’s ability to function properly. Uninstalling it has brought everything back up and working properly. Unbelievable. Thank you, Microsoft. JCR

1 Like

Yeah, the latest round of updates have been breaking things.