Another odd screen issue

Another day and both my home and work systems have the display problem back.

I still can’t reproduce this.

What I can do is provide you with an update to the extension (it’s updated against the latest stuff from Roon) and test with that see if it makes a difference.

Regards Harry

Hi @Lloyd_Borrett and @Nathan_Wilkes,

I pushed an update to the extension out. It means that your system will update the extension, depending on your update settings.

It can be that you need to enable the extension (0.9) again. Let’s see how this goes…

1 Like

Thanks Harry. My endpoints needed another reboot (in addition to the automatic one about 5 hours ago), and then yes the displays needed to be enabled in Roon. At 151 and 0.9

I appreciate the work you do — thank you.

Nathan

It seems like I am having the same issue as before — the display simply freezes. A restart of the extension resets the display, but then after a time goes to sleep (eg the clock).

057ec9759ccc6078

But, I am not convinced that this is a RoPieee issue, or wholly so, as I wonder whether the issue is a networking problem. One interesting thing is that last night the Roon application thought that my Core was on the NUC wireless IP, rather than Ethernet IP. And, when I went to restart the NUC just now I had to use the wireless IP as the Ethernet IP wasn’t responsive via http (I test ICMP every 10 minutes, and I see no outages, strangely.) As a test, I have disabled wireless on the NUC running Rock, and of course all displays (right now) are behaving nicely.

@Lloyd_Borrett, you use ROCK, yes? Do you use the wireless interface as well?

@spockfish, you may recall back in January I set a cron job to restart the extension every 4 hours or so to mask a similar problem I had then. I changed the interval yesterday to every hour, but I’ve changed it back to the original schedule to evaluate this latest change.

Again I can’t read the feedback archive.

I’m wondering if something else is wrong: a busted SD card…

Interesting. This is the RoPieee that ran out of space. I’ll re-flash.

Harry, try this one (after a reflash): f95db19495bb2c19

BTW, I see that the default is to not reboot on a schedule and to check for updates on boot — is this now the recommended setting?

My home network has the ROCK and RPi DACs connected via NetComm Ethernet over mains power adapters. The laptop and iPad that I use as control devices connect to the network via wireless.

My work network has the ROCK and RPi DACs connected via CAT6 Ethernet cable. Again, the iPad and smartphones that I use as a control devices connect to the network via wireless, but the laptop is connected via CAT6 Ethernet cable.

I rebooted the RPi with touchscreen and the ROCK on the home network last night. Then re-enable the extension. So now on 0.9 and all is okay so far.

I have three RPi DACs on each setup, but only one on each network has the touch screen.

I just rebooted the three RPi based DACs and the ROCK on my work setup. RoPiee has updated to 151 and the extension is 0.9.

Screen update problems still present. Plus I just noticed another issue. I can use the touch screen to move back and forth between the tracks, The display doesn’t change. I can pause and play the track with the touch screen, but the pause icon doesn’t change back and forth between play and pause.

can you send me feedback?

I selected an album and sent it to my Pi 3 B+ with touchscreen and Audioquest Black USB DAC. It started playing immediately. I glanced over a few minutes later to see what track was playing and saw the display was showing the clock. I touched the display and got a message saying there was a connection failure. I tried restarting the Roon Extension but got no display so I restarted the Pi, restarted the track in progress and got sound but no album display, just the connection failure.

The Pi is running version 151, set to update daily using the stable channel and reboot weekly.

Feedback is a117a716336ec9e8

Let me know if you need more information.

Tim

HI Tim,

Thanks for the feedback. This bug is killing me…

Anyways, you’re not updated to the latest version. I pushed out a small update yesterday (152), so can you update and see if this makes a difference?

regards Harry

Yeah it’s the new default. Does not make that much difference.

Hi @anon97951896, @Nathan_Wilkes and @Lloyd_Borrett,

I’ve pushed out another update.
Don’t get your hopes up to high, as I can’t reproduce this the only thing I can do is increase logging.

Anyways, would be great if one of you guys can try this out.

Regards Harry

Harry @spockfish

I changed to update on boot and rebooted. Went straight to the Connection Failure screen. Can still play music using the Pi.

I still see version 151 but the ropieee-version package says it is 153-1. Hoping that means I got the update so I’ve sent more feedback 69f992d95df8b7b0

Thanks for looking into this … Tim

Guys, can you tell me a little bit more about your setup?

I’m slowly, very slowly, thinking this might be outside RoPieee.

Ok… I think I’ve been able to track the ‘why’: the extension is not connecting to Roon core…
I can’t explain why this isn’t happening for me.

So guys, you have enabled the extension right? In Roon? It got a new version number, hence you need to re-enable it.

Just saw your last message. The Spockfish extension was not enabled. I just enabled it and the screen now shows a track from Neil Young’s Rust Never Sleeps … appropriately Hey Hey, My My (Into The Black) :smiley:

You probably can ignore the rest of this message since I doubt my configuration is related to the need to enable your extension.

Still playing music. Error screen timed out and went back to clock. When I tap the screen it goes back to the Connection Failure screen.

My endpoint is Pi 3 B+ using a WiFi network connection and a DragonFly USB DAC. Single power wart split to connect to the Pi and the screen. Touchscreen and Ropieee obviously.

Was using wired Ethernet for the first couple of months but I moved the Pi and had to switch to WiFi several weeks ago. Was working as expected. Not exactly sure when it started failing, I went out of town Friday and got back late Saturday and may not have used it until today. I know it was working last Thursday. It was set to update Daily until I just changed it to update on boot a few minutes ago.

Tim

Ok thanks. I’m using it over wifi as well, so that’s not it…
So… can you hit the feedback button once more?