Any local file at 24/192 and Above Not Playing Properly

Roon Core Machine 1.8 build 884 64 bit
Windows 11; Intel i7 8700K 32 gigs ram 4tb Segate HHD; Kef LS50 Wireless 2 speakers ; Xfinity Router wireless connection 5G

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

Currently the only way to access my local music files to my newly-purchased Kef Wireless 2 speakers is thru Roon. If I attempt to play any file at 24/192 or above, either local files or via Qobuz/ Tidal, the file breaks up and stops playing after a few seconds. HOWEVER, if I try streaming the same file from one of the above-named services thru their own app or the Kef Connect app (bypassing Roon) the file plays FLAWLESSLY, telling me that the problem lies with Roon. Since I am the only music listener in my household I was hoping to avoid having to install a NAS just to have access to my local files; however, I have many high res files, including DSD files, that will no longer play with the Roon/Kef combo. Please note that reducing the resolution to CD quality does fix the problem but it still doesn’t answer the question as to why the files stream perfectly well when not using Roon. Any help/suggestions would be greatly appreciated.

Do you have any way of getting an Ethernet cable to the KEF’s ?

Maybe a WiFi extender with a RJ45 socket ?

I could do that but the cable would have to be stretched from my speakers by my TV across the floor to the opposite wall where the router is. Hard for me to believe that a WiFi extender would help when the speakers and router are only 10-15 feet apart.
Something to consider I guess.

I have used this “trick” before think of it as a big aerial.

If you can run a cable just to test at least you can eliminate WiFi if it sill skips , my bet is it won’t.

Interference with WiFi is notorious, Google it !, microwaves , other peoples routers especially on 2,4 ghz

Is your 15 feet “line of sight” or through walls ?

1 Like

I’d second @Mike_O_Neill’s suggestion to test with a cable. If it does solve the problem then you could run a flat ethernet cable around the edge of the room. I’ve used a couple of these in my own house - to add a wired backbone to my mesh system. They work well and blend in much better than round cables.

1 Like

I just recently spent a lot of time troubleshooting an issue I was certain was not a network issue. I found three 24/96 tracks that would stop mid-way 100% of the time when going from my Nucleus Plus to my Atom using Roon RAAT.

Like you, I used other streaming methods and sources for those songs, and they would play just fine.

My wireless router seemed very stable in everyday use. I live in the woods with my nearest neighbor 200+ feet away from me, so the most wireless interference I get is when I run my microwave. During testing I even moved the Atom closer to my router and only had the devices I was testing with connected to my router, both wired and wireless.

I finally discovered by switching my Atom from 5GHz to 2GHz, it no longer had the issue. I also discovered if I left the Atom on 5GHz and changed the Wireless mode and/or NAT Acceleration options on my router, I could get it to work. I did not try a wired connection, but I’m betting that would have fixed the issue too.

My router was an ASUS RT-AC68U that I bought in 2014. Even though the RT-AC68U admin page showed I had a good signal, and the basic network monitor showed a very steady low-rate stream to my Atom, my RT-AC68U apparently did not like those tracks. I decided it was probably getting too old and purchased a new router. I’ve only had the new router a couple of days, but so far so good.

Even though your issue is a bit more repeatable since it happens for every 24/192 track you try, it does intrigue me that your issue sounds similar. Hopefully testing with a wired connection will get you pointed in the right direction. Good luck!

If you stream outside of roon it goes to the kef still compressed. If you stream via roon the flac is uncompressed to pcm in the server and then to tge kefs so it’s a bigger load on the network.

First of all, thanks to all who replied. Your input is greatly appreciated!
I have found a ‘fix’ at least for now. I uninstalled the program and all its components, including going thru the Windows registry and deleting all references I could fine. Then I reinstalled fresh as if it was a first time install. Roon now is playing all files smoothly regardless of resolution.
I also dug up an old cat6 cable and connected my speakers to the router. According to the Kef Connect app my speed has increased 10-fold, so I guess I’m good to go!
Thanks again to everyone. Happy listening!

4 Likes

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.