Anyone else noticing Roonbridge instability?

I have my Core on a Win10 machine and Roonbridge on a Win7 machine connected to a W4S DAC2. When the Win10 machine sleeps or reboots, and core is running, it won’t “reconnect” with the Roonbridge (or Roonbridge doesn’t respond). It shows as available, but hit play and nothing happens. It doesn’t skip tracks. It just doesn’t respond.

Before I reinstalled Roonbridge the audio zone would flash on and off in the bar at the bottom of the interface. Now it doesn’t flash (after reinstalling Roonbridge) but it is still unresponsive. When I go to task manager and kill RAAT and Roonbridge and then reload, all works again.

This appears to correlate with a relatively recent release of Roon. Started a few months back. Didn’t reconfigure windows or Roon in any way - it just started happening.

Hello @James_I,

So we can better assist you, please describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Does this behavior occur with any device connected to the Windows 7 machine, or just the DAC mentioned above?

The next time this behavior occurs can you note the time that you try to play to the DAC so we can enable diagnostics and take a look?


Hi Dylan-

Network topology is entirely wired. Win10 Core->GB Ethernet Switch->Win7 RAAT endpoint ->USB to W4S DAC.

I do not believe the issue to be related to connectivity. It is that if if the core sleeps or is rebooted, RAAT has to be restarted at the endpoint to get it to respond. I can hit the play button, but nothing happens. It still shows up as an available zone, but it’s frozen.

The only device connected to the Win 7 machine is the DAC, other than mouse and keyboard, which work fine.

Had this problem today at about 11:23 CST. Then I opened task manager, killed RAAT and Roonbridge and restarted, and then the zone functioned again.

There is something about the Roon core sleeping or being rebooted that affects Roonbridge and it has to be restarted.

This is recent. I haven’t changed my computer sleep settings etc. recently - it is some change in Roon, I think about the time that the MQA version came out, that started this problem.

Thanks for the update, @James_I.

Thanks! Now that I have the timestamps, diagnostics have been enabled on your account. The next time your Core is active a diagnostics report will automatically be generated and uploaded directly to our servers

Once that’s been received I’ll be sure to pass them along to the team for analysis and will update you once I’ve received their feedback.

Hi @James_I,

Thanks for your patience while the team is investigating. I had a chat with them today and they asked that we gather some additional details here that I’m hoping you can help me with.

Do you have remote desktop software installed on the Core machine or the RoonBridge machine? If so, what software?

Is this device using ASIO or WASAPI?

When this behavior occurs if you disable the device and re-enable it in Roon without closing RoonBridge are you able to play to it like normal?


Hi Dylan-

I was out of town for the holiday and so just getting back to you. The above usually happens when the Roon Core (Win10) sleeps. But it just happened when the music was paused for about an hour.

When I went to settings->audio, the WASAPI driver for the DAC was stuck on “enabling” and the ASIO driver had an error message that scrolled off the screen. I don’t recall that I even had the ASIO driver enabled and it didn’t show up as a zone.

Disabling and re-enabling the audio zone (device) did not fix the problem. I still had to kill RAATserver and the other Roon processes on the bridge machine to get it working.

No remote desktop software running on the core. On the Roon bridge machine, I had WinVNC server on it. I uninstalled it since I haven’t used it in over 5 years.

I was using WASAPI for the DAC.

Come to think of it, this started happening after I unplugged my Pro-Ject S2 digital but left the drivers installed. I wonder if those drivers are interfering somehow?

Hi @James_I,

Thanks for the update here. Based on the information above, it sounds like there’s a driver issue at play here. First, I would uninstall the drivers for the Pro-ject and see if there is any change. After that I would uninstall/reinstall the drivers for the current DAC and see if that yields and improvement.