Anyway to run Roon on an iphone via a VPN?

I run Roon on my iphone without a problem when I am on my LAN at home.

Is there is anyway to do the following:

I connect to my home network from my iphone (when I am on 4g) via the built in VPN client, which connects to my router which has a VPN server and sets up an L2TP connection between the two.

So, my iphone has a public IP and has access to my home LAN as well.

Is there a way for the the Roon client on my phone (public IP) to communicate with the Roon server (LAN subnet)?

No. You would need a layer 2 VPN client which iOS doesn’t support.

Also search the forum before posting, there are quite allot of topics regarding this subject.

Oops, sure, sorry about that :slight_smile:

1 Like

Well in these other threads there are always these guys suddenly popping up, that claim that it works on their iPhones and they could even post a guide - but then they miraculously vanish again - with all their wisdom. Ah well that is the internet for you :relaxed:

So, the sad and true answer is, it does not work with ios. I really wished it did.

It worked for a bit for me using Synology HTTPS based VPN to my Synology router and then an update broke it. I don’t think there is a 100% guaranteed solution. That said I have seen mention of possible success with the VPN server and core on the same machine.

If only Roon had remote/offline playback capabilities. It’s been on the planned list for 3 years now…

I really do not understand why they are so slow at this. It has even been announced that they are working at it. Come on free solutions like LMS can do it and work perfectly together with cheap iPeng.
We live in a very mobile world, where people are on the road, live in hotels, or travel for work etc. Having a licence should give them the possibility to listen to their music, without the folks at home not hearing anything anymore (licence switching) Times have changed, we move around a lot more.

@DrTone, it worked for also using Synology HTTPS based VPN but not now anymore (since about a month ago). You wrote that a update broke it. I am curious which update caused the problems because I do not know.

I had it working for months on my iPhone using VPN to the MacMini running the core.

The 1.6 update broke it :frowning: which was very disappointing, as I’d gotten used to being able to stream my home library to my iPhone while on the road.

FWIW, the interface still loads (i.e., you can VIEW your library), but the iPhone no longer appears as a zone so you can’t play your music :frowning:

This is exactly why I also keep JRiver running as a service on my home machine (which also runs the Roon Core). One click with JRemote on my phone or tablet from anywhere and I’m instantly connected to my home system and my personal library. I can also make that work with iPeng too but it takes just a tad more tweaking.

It’s still working mine. As I am running the core on the Synology nas, it may not be running on 1.6 yet I think

It’s working here.

  1. Latest Roon Server version (nothing too fancy, except it’s running in a container on a NUC)
  2. SSL VPN (“Synology VPNPlus”)
  3. IGMP snooping needs to be enabled in your router configuration <- this is key
  4. Using Synology VPN Plus app on the iPhone, I’m able to play on the iPhone over LTE

It use to work without IGMP snooping before, but no longer (not too sure why, but then this is what might have changed with 1.6).

Hope that helps.

@Dubo_Dubon_Duponey. Thanks for your post. I have a few questions:

  • Do you have VPN Plus Server running on a Synology Router?
  • If yes, have you enabled IGMP proxy in the router and if yes with which version (2 or 3)?
  • Have you in the Synology Router forwarded some special ports to the NUC and if yes which ports?
  • Which version are you using on the Router (firmware), for the Roon server on the NUC and on your iPhone (iOS).

I am asking because I do not get running Roon over VPN on my iPhone.

Thanks in advance for your reply.

  • VPN Plus running on a Synology router rt2600ac
  • IGMP snooping enabled on the router itself (version 2)
  • no port forwarding
  • router: SRM 1.2-7779 Update 1
  • iPhone: iOS 12.3.1, Roon for iPhone 1.6 (416)
  • NUC: Debian Stretch, Roon 1.6 (416)

@Alfred_van_Hoorn want to share a screenshot of your vpn settings?