App stops playing frequently

I use the app on my new Samsung S tab and after a view songs it stops playing music. When I switch to the app it is searching for the library. When found after a few seconds I can resume playing music.

Is this a bug in the app? i use it with an bluetooth reciever and it is very annoying. I am sitting nearby my router so WiFi is perfect.

Regards Ronald

1 Like

I am experiencing the exact same problem. Does anyone know what the fix was, or if there is one?

Nexus 5X android phone
Android 7.1.1
…and I can provide more data if needed.

Thanks,

Peter

Just a thought; have you got your wifi set yo turn off when the device sleeps or the screen goes off?

As that would cause the disconnect…

Thanks, mannp. I appreciate the help.

That was the first thing I checked, and I don’t believe that’s the issue. Other apps run fine – for example, the Tidal app will run no problem, but the Roon one won’t.

Peter

After some experimentation, I’ve found two solutions. I thought I’d post them here in case anyone else runs into the same issue.

Copying @support just so they can add it to their knowledge base, as I can’t imagine this would make the Roon priority list unless one of their engineers gets a bluetooth speaker that they need to control via an Android device, in which case it would probably get fixed quickly. :slight_smile:

Solution #1: An app.
As this issue is somewhat common, there are multiple apps in the Google app store which keep your WiFi connection alive. As I write this (March 2017), there are 3 that I’ve found: WiFiKeepAlive, Wifeeper, and Best WiFi Keeper.

I presume all 3 would work, but I started with WifiKeepAlive and it’s solved the problem for me so I haven’t tried the other two. It’s free.


Solution #2: If you don’t want to go down the app route, the other solve is to go to: Settings/Display/Sleep and change the length of time it takes before the screen turns off. You can set it to 30 minutes maximum. As long as the screen is on, the problem doesn’t happen. The downside of this solution is keeping the screen on for the entire time is a big battery drain.


What doesn’t work is turning off Battery Optimization for the Roon app, or setting your WiFi to “always on”. Neither solved the issue.

I hope this helps,

Peter

Thanks, @Peter_Karpas. I’ve been struggling with this issue for a couple of weeks now. Neither solution is ideal. @support, a proper fix for this issue would be very appreciated.

I’m starting to think that Android (particularly mobile) isn’t a high priority for Roon given the lack of official responses to many issues and suggestions logged in this forum, but having playback stop after 5 minutes unless you keep your screen on or download a third-party app is a showstopping defect IMO.

Hey @Scott_Johnson1 – we have not done a lot of Android-specific work over the last few months as 1.3 came together, but that’s because Roon uses the same infrastructure and code on all platforms, save for a few platform specific details, and we weren’t working in those platform-specific areas very much for 1.3 on any platform.

I should, however, mention that our Android audio implementation was completely rewritten about a year ago, which is after this thread started, and that will likely happen again in the future as our Android app evolves to support “on the go” use cases.

That said, I of course agree that playback shouldn’t stop after 5 minutes. Issues like this usually relate to power management–Android shouldn’t be turning off when music is playing. If this problem got worse over the past few months, it’s possible that Google changed things out from under us.

I just ran a quick test here, and playback did stop for me after about 15 minutes. I’m going to forward this report to our QA so they can write up the report and pass it to our developers for further investigation. Thanks for the report!

Thanks for the response, @mike.

My playback used to stop after 15 minutes, but it stops playing after 5 minutes since I’ve upgraded my Galaxy S7 to Android 7. My music apps that play files stored locally on the phone (PowerAmp, GoneMad) don’t have this problem, so there must be a solution.

I look forward to seeing a fix, hopefully soon!

Thanks again.

Just got back to using Roon again, and ran into this problem. But it is nice to see that the problem is already known, and hopefully a fix will be coming.

Hi @mike, any update on when the fix for this issue is coming? It’s been a couple of months since the defect was logged. Thanks!

This ticket is still open in our system, but we’re getting there. There were some underlying changes needed in our Android build process that needed to be resolved before we could work on this bug directly, and we’re nearly done with that work.

I can’t quite make promises on timeline yet, but we’re actively working on this and I’ll have updates as we get a little closer. We’re on this, and we appreciate everyone’s patience.

1 Like

This is now stopping for me and crashing shortly after.

Restarted the app 5 times in 20 minutes and submitted two logs through google crash process.

Gone to use my spotify 3 month trial so I can actually listen to some music.

@mike @support Any updates on the fix to this issue? It’s been out there for a long, long time now.

Given what we all pay for Roon, I figured we would see faster fixes to major defects like this! I’m a bit disappointed by the long timeline for this fix and the lack of communication about the status of the defect.

Sorry for the slow response here @Scott_Johnson1 – we actually closed the ticket tracking this issue out in our system in early June, but it looks like we never circled back to this thread. Apologies for that.

So, after our developers addressed some underlying issues related to our Android processes, our QA team was able to pass them this report for investigation. They had been able to reproduce the playback stoppages consistently, but once these were investigated by our developers we discovered that Android was simply shutting down the app once it had been in the background for a few minutes, probably to save battery life.

With some additional investigation, we were able to confirm (at least in our testing) that going into Android’s Battery Optimization feature and setting Roon to “not optimized” resolved this problem. I’ve tested myself and I was also able to listen for an extended period without issues.

Reading back, I realize that some people in this thread have tried this without success so I’d like to get a clear sense of who is still having issues here.

We do have some work coming up that will involve rewriting a good deal of our code for audio playback on Android, so if there are issues now, please let us know. And again sorry for the slow follow up here @Scott_Johnson1.

1 Like

Hi @mike,

Just in case you haven’t seen, there are threads on this issue returning in Android 8.0 Oreo here and here.

Vog

1 Like

Hi
Roon and Tidal stops now, in the start it works very well.
I get “Transport playback error endpoint device init fail” when i use Roon

@mike, I still have this problem from time to time.

What I’ve discovered is that Roon works fine and doesn’t stop playing if I leave it up on screen and don’t lock my phone. It seems to prevent Android from locking and continues playing without interruption. It’s not a great solution from a battery life perspective, but it works well enough for now.

If I switch to a different app and walk away from my phone, the phone locks and Roon stops playing after a few minutes. Similarly, if I lock my phone Roon stops playing after a few minutes.

I use a few audio apps (PowerAmp, GoneMad, Spotify) on Android, and Roon is the only one that has this problem.

I’m still on a Galaxy S7 Edge, running Android 7.0.

Hey @Scott_Johnson1 – it really sounds like you’re seeing Android shut down Roon in the background to preserve battery.

I assume you tried this already: