Apple iCloud almost full messages?

Apple is sending me emails saying my icloud is almost full. When I go to settings on my ipad and open up icloud to view the contents there is nothing in there. When I try to manage the account all it will let me do is buy more storage. Can anyone tell me what is going on? Thanks

If you log into iCloud via a browser and go to settings what does the storage usage say.

Best way forward would be to call the Apple support number for your location.

1 Like

I have been having similar messages for the last couple of months.
I don’t actually store anything in iCloud as I pay for Google drive and OneDrive. It’s very annoying that the richest company in the world still wanted more and more.

1 Like

Yeah, it should all be free, but apparently the future is in subscriptions :joy:

Actually what is annoying, is how hard it is to figure out what’s happening. On an iPad, click Settings > your apple id > Storage > Manage Storage to try and figure out what’s eating it all. Perhaps all @John_Kaster needs to do is delete a few emails with big attachments?

2 Likes

Mike possibly so, and I will be honest enough to admit that I just can’t be bothered to look at the moment.
I don’t store anything I have turned backups off, I don’t back up photos there.

I will probably get a nice surprise when I finally log in and see what has eaten that whole 5GB of storage and go… Oh yeah I remember doing that several years ago :face_with_hand_over_mouth:

3 Likes

Automatic backups will eat it up quickly, especially if you have a few “i” things. But it’s worth checking what’s going on before clicking “buy more” for sure.

3 Likes

I have checked my iPhone and iPad and the answer is nothing at all. That’s why when I finally look on the web I will be completely embarrassed at my school boy error :joy:

1 Like

Could be you have loads of apps installed that are backing up using iCloud.

1 Like

Yes. I don’t know when this started, but all the data cached (such as album cover images) by the Roon app on my iPad was being backed up to iCloud. To turn it off, go to Settings, select your name (upper left), then iCloud (mid right), then Manage Storage (upper right), then Backups for your device (mid right), and finally turn off the Roon app slider in Choose Data to Back Up. That’s it!

2 Likes

So Mike you embarrassed me into checking and one of my iPads had created a backup which was taking up 90%+of my iCloud storage.

Now I have all my storage available again.
Thanks for the motivation :grin:

3 Likes

So when I select and hold my id it showed me all the backups. I’ve recovered all my storage. Thanks everyone.

3 Likes

Try clear Roons cache and restarting it. My icloud backup went from 5gm down to 2.5gb (free space). You can look in the space used for storage on the apple to get the size of Roon on each of yoor apple devices. You can select another option for icludd storage, iit is the bottom selection, ofteh hidden/not displayed properly.

This is a known problem to Roon, I reported it about 2 months ago and they were already aware of the issue. The space used gradually ihcreases until you do the clear

Try logging in on your pc.

You might have to try iCloud Drive and iCloud.com to delete photos, Mail messages, contacts, documents etc.

I recently ran into the same situation and with Apple’s help with these two options I was able to delete tons of photos etc.