Apple TV Airplay Code

When enabling Apple TV as a Roon Tested device, it prompts for an Airplay code, I enter this in. However, my Apple TV doesn’t confirm it. Every time I try playing to it, it prompts for a code.

I have tried change the airplay setting to everyone, and back. Restarted the Apple TV. I have restarted Roon, as well as removed the device. I have tried WiFi and Ethernet to the Apple TV. Interesting thing when hard wired, the IP address changes or flips in the roon interface. My guess is channel hopping or something.

Thoughts?

I don’t know if this will help but there is a workaround here.

Please try changing your ATV Airplay settings, and require a password.

A) Open settings on the AppleTV
B) Navigate to AirPlay and Homekit
C) Tap on “Allow Access”
D) Set “Allow Access” to “Anyone on the Same Network”
E) Set Require Password to “On” and create a password
D) Back out of the menu to the home screen
F) Try to enable the zone in Roon. It should ask you for the password

4 Likes

This worked. Thank you.

1 Like

this procedure worked for me, too. THANKS!!

1 Like