Application install post-update failed

Turned on Roon and I got an error message.
Application install post-update failed (1892731). Please reinstall the latest software.

I reloaded the software but I keep getting the same error message.

Moved to the support thread and added @support.

Hi @Scott_Savold ----- Thank you for the report and sorry to hear of the troubles.

Moving forward, would you kindly please use this link as a guide and give us the details of your setup. This way we have a better sense of what you are working with.

EDIT: I did a quick search of community and came up with the following thread, where the same error was being reported. It appears that the fix was to delete the application and reinstall:

“Ok got it running - needed to delete old app and reinstall. Saved the Roon folder with db info so it’s all good to go.”

While it is unclear to me what device your core is being hosted on, if you happen to be on a MAC would you kindly give the above a go and let me know how it turns out?