Applying library settings taking several days after Core migration

Core Machine (Operating system/System info/Roon build number)

Win10, build 1903 / x64 laptop i5-3230M, 6 GB RAM / Roon Server 1.6 (build 416)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

All wired gigabit intranet

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Sonos Connect:Amp (3x) and Linn Akurate

Description Of Issue

Some two weeks ago I started my free trial and after a few days I knew Roon was a keeper.
Consequently I needed to migrate the core from my work-horse i7 PC that I like to be able to close down every once in a while (especially at night), to a machine that uses less electrical power. I decided on my i5 laptop, for starters, because maybe later on I will build a dedicated new headless pc just to run the core and the extension manager.
So I performed the three basic steps of core migration:
a) backup of old core on PC
b) installation of Roon Server on laptop
c) restore of backup to core on laptop.
After the last step all seemed well at first sight. From the newly installed Roon client on my PC, connected to the new core I could see that the all my (200k+) tracks had been imported:
This import had initially taken days on the old core. So I was confident that the backup / restore actions had worked well. But…
I migrated on Thursday November 7th and today, Sunday November 10th, I still see this wheel turning in upper right corner of the Roon UI. And after clicking on it, it says:

This blue bar under ‘Applying Library Settings’ was at say 95% three days ago and now it’s at a little under 100% but incresaing by only a very little each day…
This I find puzzling.
Why the need for ‘Applying Library Settings’ if I have copied the Roon database via the backup / restore route? I also made sure that the drive letter assigned to the music share on my NAS is the same on my PC as on my laptop (M:).
Perhaps I do not fully understand what ‘Applying Library Settings’ means exactly and perhaps someone can illuminate me in this matter.
But most of all I’d like to know if it is considered normal behaviour for the Roon core to take so much time for the application of the library settings after a migration?

Because of known problems with the integrated graphics adapter, you should make sure to use the 32-bit version of Roon. Further question: Is Roon installed on an SSD (system partition of the laptop)?

Yes it is installed on an SSD!

Is the connection to the music library via WiFi or lan? Or is it direct connected via local drive/usb

Thanks for your quick reply, @BlackJack
Considering the integrated graphics adapter, I noticed that when I ran the full Roon on my PC, the GPU usage was very high during indexing but smoothed away to normal low values once everything had settled. By the way, as far as I can see the GPU on my laptop is not used at this moment on my laptop. Is that (part of) the “known problems with the integrated graphics adapter” you mentioned?

I was and still am not sure which processes were delegated to the GPU and which ones were delegated to the CPU. One thing I did notice was that CPU usage on my i7 PC was very high (over all 8 cores) when Roon was still processing all audio files in the Background Audio Analysis. Am I right in assuming that these data would not have to be mined again after the migration, since I am using a one-on-one copy of the Core database on my laptop now?
Which brings me to my second question:
What exactly is Roon doing while “Applying Library Settings”? And should the CPU or the GPU be carrying out this task?

Some other matters to consider:

  • Playback is normal, without hickups, even with 24 bit FLAC files.
  • The UI experiences of the Roon remote on both my PC and my tablet are perhaps a bit sluggish but very much comparable to the situation while “Applying Library Settings” when the Roon Core still resided on my PC.

It is connected via UTP cables over a gigabyte switch to the QNAP NAS. I only use WiFi for remote control (Android Phone and Tablet) and of course the Sonosnet is wireless.

The intent of my answer was primarily to inform you about general knowledge based on older threads and to gather additional data missing from your OP (which seems to be the case too for @wizardofoz’s question) so official support has already more data available when showing up.

Hi @Hans_Valeton,

Is the “Applying Library Settings” message still visible if you reboot your Core machine?

I can’t say that I’ve seen this message often before, I would expect to see it if you were to change your import settings in Roon Settings -> Library -> Import Settings but not just by transferring the backup over.

Did you make any changes in the Import Settings tab? Do you see any activity under “Background Audio Analysis Speed”?

Hi @noris
Thanks for replying.
In the meantime (as advised by @BlackJack) I have tried to use the 32bit version of the Roonserver instead of the 64bit one that I had installed on my laptop when first starting this thread.
But to no avail, I couldn’t seem to connect from any of my clients to this 32bit Roonserver. Could it be that a conflict arose between a freshly installed 32bit Roonserver and the backup that was made earlier from a 64bit full Roon install?

So I uninstalled the 32bit Roonserver again and re-installed the 64bit version and restored the backup again. Succesfully so, because within the hour (approx.) the core was up and runnung and showed all of my 217000 tracks.
Remote control from any of my clients is very slow, though. It takes minutes to start playing the tracks I add to a queue. CPU usage of the laptop (running the Core) is about 50%, but memory usage is at 90%.

This time, shortly after restoring of the backup I did make a change to the Import settings.

Before the change the first setting read:

  • Tag Delimiters for Artist/Composer/Label tags: ; , (semi-colon AND comma)
    So now it’s only logical that the core is (very) busy applying the new library settings. At this moment the progress reads:

    Some tracks are added each day so I’m certainly not worried about the first progress bar. It comes and it goes.
    The second progress bar has been steadily growing and I think (hope…?) that the application of library setting process will be finished tomorrow. I keep my fingers crossed.
    If the progress starts to lose momentum as it did before, I will add a new reply in this thread.

I have not tried rebooting the laptop since re-installing the 64bit Core again. Should I try that? Would that be wise even while it is so busy?

Yes I did, as I’ve written above.

I don’t see any activity here:

A question pops up: Will the “Adding Music to Library” and “Applying Library Settings” take longer with remote clients connected to the Core or does that not make any difference at all?

Hi @Hans_Valeton,

It does seem like you have quite a large library here, and any changes to import settings would take a while to propagate to all the files.

After the first progress bar completes, can I please request that you send me a copy of your Roon logs by using these instructions?

Hi @noris

The first progress bar has completed:

My laptop running the core is still quite busy…:

I have shared my zipped log directory here:

I had once again become frustrated with the fact that the second progress bar “Applying Library Settings” had seemingly come to a halt and so, at the end of this morning I stopped the Core, rebooted the laptop whereafter the Core started again automatically. And lo and behold, within a few hours the “Applying Library Settings” process finished!
To my big surprise however, at about six o’clock in the afternoon, Core decided to go through all of my audio files once again:

This progress bar doesn’t move at all. But the first number (of tracks) has been counting down relatively fast. It probably started at 217,000 or thereabouts, and now it seems to have passed the half-way mark.
But what is it doing? And why? :astonished:

The above image shows that all my tracks have been imported.

There appears to be no Audio Analysis going on:

The laptop running the Core is obviously having lots of i/o with the NAS:

Hi @Hans_Valeton,

Did anything change around 6PM? Did your re-connect your storage device by any chance? Is the behavior still the same at the present time or has the rescanning stopped?

I’m not sure, @noris, but later that evening Roon suddenly overruled the Sonos software I was playing music through and started playing something that I vaguely remembered putting in the Roon queue quite some time before. That happened during dinner and after dinner I took a look via the client on my PC and noticed that all progress bars had disappeared.
The CPU usage on my laptop running the Core however was at 100%. But that was easily explained by Background Audio Analysis going on, due to a fairly large number of tracks that I had added to my collection, earlier that day.

So, for now all is quiet. The clients are medium responsive and so this setup is workable for the time being. In the future I will certainly be looking for heavier equipment to run the Core on.

By the way, did you find anything of interest in the logs?

Hi @Hans_Valeton,

I just took another look at the current diagnostics from your PC and I am noticing quite a few issues, it seems that you might still be experiencing issues even at the present time?

I see that RAATServer is having issues maintaining a connection to the localhost (itself) which usually indicates that something is going wrong here.

If you are experiencing issues on your end, I would suggest setting the current database aside and trying to restore from your backup once more, you can use these instructions to do so:

  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “RoonServer” & “RAATServer”
  • Rename the “RoonServer” folder to “RoonServer_old” and “RAATServer” to “RAATServer_old”
  • Reinstall the Roon App to generate a new Roon folder
  • Try restoring from your backup once more

Can you give that a try and let me know if it helps?

Tanks for your reaction.

Do you mean the the logs I sent you six days ago, or are you able to monitor my Roon core remotely, in real-time?

Having a look at the logs I sent, I can’t find any occurences of “client connection failed” or any other warnings.
When going through more recent logs (of this morning) I found many occurences of
"11/19 06:55:54 Trace: [raatserver] [RaatServer WAGNER @] client connection failed. Giving up"
Is this what you mean?

Now I am running a Private Internet Access VPN on the same laptop that the Core resides on, which potentially could mess up internal connections. I did however experiment with adding some “exluded apps” (Raatserver.exe, RoonApplicance.exe and Roonserver.exe, all located in the %localappdata%\RoonServer\Application directory) to the PIA settings but apparently these settings couldn’t prevent the connection problems shown in the Roon logs.
When I disconnect/disable PIA, the Roon connection problems cease to exist, as I have just found out this morning. Does this mean that running both PIA and Core on the same machine is a definite no-go? Or have I set the wrong exclusions?

I have tried rebooting the laptop a number of times, and sometimes, but not always, the Core starts trying to identify all unidentified albums of which I have 3770, and this makes connecting from a remote client to the core impossible for quite a few minutes. Is this standard behaviour? Can I change it in the settings?
The last time I restarted Roon, it did not try to identify all those unidentified albums and the start-up was significantly faster.

Do you still think I should try and start with a new installation from scratch and restore my latest backup, as you suggested?

Thanks for your time!

Hi @Hans_Valeton,

This could explain the behavior I was seeing in the logs for sure. Running a VPN and Roon at the same time can cause all sorts of strange behavior, including the localhost issue. I would avoid using the VPN and Roon at the same time.

Where are you seeing this identification take place, in the “Activity Spinner” in the top-right corner? Can you share a screenshot if so?

We just released Roon 1.7 today, I suggest to upgrade to the newest version and verify if these issues carry over. If they do, please provide a screenshot of the spinner info. Thanks!

Hi @noris,
Yesterday morning I started the upgrade to 1.7.
Since then the spinner has been rotating continuously. But that’s only logical, seeing as the entire library needs to re-scanned by the new 1.7 Core software.

I noticed this while checking the logs. The entries there read something like “identifying unidentified album(s)” (if I remember correctly) and there were very many such entries.
I can’t give you any literal examples now since the log files have all been overwritten in the meantime.

Then I’d like to place a “feature request”: please make the Roon software robust enough to be able to cope with a VPN (such as e.g. PIA) because I’m sure I am not the only one using a VPN.