ARC - almost there . .

Roon Core Machine

Hostname: zen Innuous Zen mk3

Networking Gear & Setup Details

Router: Calix Exos
WiFi + wired

  1. Who is your internet service provider?

  2. Please list the make and model of your modem and router?
    Calix GigaSpire GS4227E

  3. Do you have any additional network hardware, like additional routers or managed switches?

  4. Does your network have any VPNs, proxy servers, or enterprise-grade security?

Connected Audio Devices

Innuos Zen Mk 3 - wired - Roon Server
Anthem MRX540 - Wired, WiFi and Bluetooth
KEF LS50 Wireless II
HP Workstation - passes through to a Teac DAC

Description of Issue -

What is the exact port forwarding error message you see in the Roon Settings → ARC tab?

“ipv4_connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“”,“actual_external_ipv6”:“null”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“server_ip”:“”,“found_natpmp”:true},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true,“error”:“<s:Envelope xmlns:s="\” s:encodingStyle="\“><s:Body><s:Fault>s:ClientUPnPError<UPnPError xmlns="urn:schemas-upnp-org:control-1-0">501ActionFailed</s:Fault></s:Body></s:Envelope>”}

Auto config does not seem to work to completion. Tried manual Config and I am stumped.

Remote GUI - enabled

If you have NAT-PMP / UPnP enabled (and it looks like that) AND have a manual port forward rule enabled at the same time, then decide for one or the other. We have seen many routers who don’t like them to be mixed

Also see this section:

Less Common Errors

Miscellaneous UPnP error

for the error message you are seeing, here:

I will disable UPnP state
and UPnP NAT-T state

then retry.

Below is my current configuration for UPnP.

Worth trying, let us know how it goes :+1:

Didn’t work. Tried a number of combinations.

This is the forwarding rule in my router. I’ve turned uPnP off in both my routers. The ASUS connects to the Ziggo Mediabox in my apartment which is the ISP’s Internet/TV box.

This is how it works for me here.

Turned off UPnP altogether.

Manually configured port. Router sees “zen” my music server.

Set port to 55002

this is the new error message
“ipv4_connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“”,“actual_external_ipv6”:“null”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}

The error message shows that UPnP is off. It would not be shown if the manual port forwarding rule worked, though.

The rule in your new screenshot looks ok as such. However, it forwards the port 55002 - is this the correct port number that your ARC is configured to use? In your first screenshot at the start of the topic it was configured to use port 17760.

55002 is what Roon defaults to on my system.

Yes, but is it using 55002 right now in Roon > Settings > Roon ARC?

If it does, clearly something still keeps the port closed. Does the router have a separate firewall section where you might have to open it as well?

yes and yes

I also tried turning off security totally and stealth mode on/off.

What about the last entry in that list? “All other ports” is set to “Reject”

Nope. Tried that too.

Hi @Gerald_Cole,

Just to be double-sure, you don’t have any second router or smart switch in this setup?

With the variables you’ve already eliminated, the error message in Roon → ARC you’ve shared suggests one of two possible blocks to your port forwarding:

  1. the ports you’ve tried (17760 and 55002) are in use by other software, reserved by your ISP, or otherwise restricted on this network, even if the listed exceptions don’t include these numbers. You’ve tried setting “Block All Other Ports” to negative for inbound and outbound traffic. First, power cycle or restart your router again to make sure those settings have actually taken hold.

Then, try augmenting the port assignment up or down by 1000 a few times in both Roon and the router port forwarding rule. (55000, 56000, 57000). Let us know if that helps.

  1. The second possibility here is that Niacom has recently added a layer of address translation to your account tier. Given your location, this is certainly a possibility, as some research suggests they only (relatively) recently added coverage in that area and may now be coping with a large volume of IP addresses that they need to manage for infrastructural purposes. While more tedious, it’s worth reaching out to Niacom to ask a) if they’re using any sort of dynamic IPv4 address assignment on your account and b) if you can request a dedicated external IP address.

We’ll be here in the meantime, please reach out with any questions.

No smart switches but there is a separate modem that converts fibre to cat6.

Niacom is still building out its infrastructure but ARC worked with my Spectrum account which had a dynamic IP structure.

I have recontacted Niacom support to open a new case. I forwarded my screenshots.

1 Like

The IP address in the router forwarding rule does not match the IP address that Roon shows.

Try changing to

Good catch but it is weird because I did check that in yesterday’s screenshot and it was .116 in the rule in the screenshot in this post:

You were both correct. I have to remove and recreate the port. The devices appear in a drop down and in that instance, I forgot and used the first one.

From: Robert Wolfley (Niacom) []
Sent: Wednesday, July 19, 2023 4:03 PM
To: Gerald Cole <>
Subject: [Niacom Internet] Re: Port Forwarding

Hi Jerry,

We apologize, but due to current limitations on the network, port forwarding is not yet available in your area of the network. As we continue to grow in service, we are working in changes that will allow customers to purchase static IPs at affordable prices thus allowing for a better port forwarding experience. Currently we are still in the planning engineering stages and port forwarding is not available in your area at this time. We apologize for any inconvenience. Please check in with us again in the future to see if we have been able to implement the features discussed and feel free to reply with any questions.

Robert Wolfley
Network Supervisor – Niacom
Phone: 716.919.3050

This email is a service from Niacom Internet.