ARC Blank Screen [Ticket in, Potential fix in EA #230]

iPhone 12 Pro, iOS 17.1.2

B222 was working OK for me but upon my first usage today the screen is completely blank.

I have tried killing all the app’s and restarting my phone and I still get a blank screen when I start ARC.

Still had the blank screen after updating to B223/B1356

In the end I re-installed the app and it appears to be working.

Hi, @oneofmany, thank you for your report, by any chance, do you remember on which screen you left the app when that happened after you woke it up? Or maybe you remember if downloads were enabled/pause, etc?



Hi @Ivan Sorry I do not remember what screen I left ARC on, probably it was the the downloads screen.

The same thing has happened again today, I got in the car and expected ARC to start up on CarPlay but instead it was asking me to log in. I then went to the ARC app, which I had not used since yesterday and I instantly had the Blank Screen of Death.

There is a fair chance that I had left the app on the downloads screen again as that is where I have been spending my time.
Smart downloads were definitely enabled, there were around 100 albums downloaded but the downloads had stopped even the the SDL icon was purple and animated.

I will post this response and if I have not heard from you or the team by tomorrow (it’s 14:40 ACST) I will re-install the app once again but I will not enable smart downloads this time.

A user on the production build is also getting a similar issue, could this be linked? Is it an iOS issue.

I updated my iPhone 12 Pro to iOS 17.2 and it is still the same.

I’m now going to reinstall ARC.

I’ve had the issue with the black screen several times on various versions of iOS 17.

I update apps daily so would have highly likely to have been on the latest Roon Arc.

Seems to be an ongoing issue.

I have still left Roon Arc with the black screen, if there is a dev build that will help to obtain diagnostics please let me know.


Hi, @oneofmany, thank you for the info. We are going to discuss this issue with our dev team.



FYI I installed 1.0.90000 (223) from Test Flight and no difference.

Still black screen.


Thanks for flagging this. Doesn’t seem isolated to downloads or EA as we’re seeing this in production as well for a handful of users. Investigating and working on a fix. :muscle:


It is a weird one, FWIW I haven’t seen this issue at all, that is until I started using SDL on B222.

And I can only cure it by deleting ARC from my phone and reinstalling.

Did you kill the ARC up before reinstalling and do you use ARC on CarPlay?

@oneofmany I assume that was to me ?

I don’t believe I’ve used it on CarPlay - I could have but don’t drive much and listen to music.

My last usage of the Arc was as follows

  • Used ARC for several hours on a long flight in Airplane mode. Would have exited the app before turning off.
  • Week later get on a train and go to use Arc and it’s dead with a blank screen.

Yes you can tell by this in my response:

also you would have been informed by an email.

Hey @michael that is strange as I don’t have the issue as long as I don’t download anything, either using SDL or manual downloads.
FWIW I never had this issue before and I had never downloaded anything to my phone using ARC.

@Michael @Ivan is it worth keeping the current state of my Arc for any diagnosis ?

Given the holidays I’m not in any great need to use Arc so can put it off for a bit if it would help.

Since TestFlight automatically upgraded me to build 224 yesterday, launching ARC only results in a black screen. Note that I never had this problem with earlier versions, and I use ARC daily.

I have tried restarting ARC and my Roon server but there was no difference.

iOS 17.2.1 on iPhone Xs Max

Roon Server 2.0 build 1356 on sonicTransporter i7

Music library on Synology NAS

Everything is hardwired gigabit Ethernet.

Mobile was tested over wifi5 with Ethernet backhaul on same switch as well as remotely over LTE.

I have not tried deleting and reinstalling ARC yet as I had already downloaded a lot of my music to it using SDL.

Getting a blank black app when launching Roon Arc

iOS 17.1.2

Have cleared all apps and restarted the iPhone

What were you doing prior to the screen being black?

Can you please try deleting and re-installing?

Using the phone with Skype, Google Chat, Slack, Email etc

Will delete and reinstall

It is now resync’ing with my ‘Core’ aka Roon Server

And it failed and now just a grey blank screen

1 Like