Arc Cannot Connect Outside Of Wifi - Virgin Media Router

ARC used to work fine and works when at home but not via internet. All latest software and running an old Mac mini converted to unbuntu as core. Hard wired to a virgin media router. Any ideas??

Hey @brennan_peyton,

Thanks for taking the time to write in! I’ve split off your reply into its own thread to ensure it receives proper attention. Following up on this thread, can you please provide a full breakdown of your system setup:

Roon Core Machine

Include your operating system and machine info (Model, CPU, RAM)

Networking Gear & Setup Details

Your network gear (model of routers/switches) and if on WiFi/Ethernet

Connected Audio Devices

Specify what devices you’re using and their connection types, like USB/HDMI/Chromecast, etc.)

Number of Tracks in Library

Tell us how large your music library is, eg. “30,000 tracks”

Description of Issue

Tell us about the problem you’re having in as much detail as possible. Screenshots are always appreciated!

With that, can you also provide a screenshot of the error message you see under your Roon Core Settings> Roon Arc?

I apologize that this is a complex configuration to think about. Could you please share /var/log or system message log after you attempt to connect ARC?


Roon Core = 2012 Mac Mini 16gb / 512GB SSD running Unbuntu

Hard wired to TP Link switch - Bluesound Node2i wired to same switch (and then to Linn AMP)

TP Switch hard wired to TP link 20 meters away via shielded Cat5 (under garden)

TP Switch connected to Tenda Router which is hard wired to Virgin Cable Modem.

0 tracks (all streamed via Tidal)

Hey @brennan_peyton,

Thank you for your patience while we’ve diligently worked to reach every request for support with port forwarding. The diagnostics you’ve provided suggest that UPnP is not properly configured on your router.

Please first try the following steps:

  • Try to enable UPnP/NATPMP in the web administration interface for the router directly upstream from your Core
  • Try to manually open the port in your router’s port forwarding configuration
  • Make sure the IP/Port matches the Port listed in Roon → Settings → ARC
  • Check for any VPNs or Firewalls that might be interfering
  • Check if your modem is in Bridge mode

If you continue to experience difficulties, please tag the support team and include the following information:

  1. Who is your internet service provider and what is your geographic region?
  2. Is your Modem configured in Bridge Mode so that it operates only as a modem or do you have the ports forwarded on both?

Lastly, please also test out hardwiring your core directly to your router, bypassing any switches :+1:

I am in the UK and using Virgin Cable. The cable box is configured as a modem only. Its connected to a Tenda Nova MESH and then directly to a switch and I can’t find the settings you are recommending - strange it used to work but now it doesn’t.

Hey @brennan_peyton,

Can you confirm the port number from your Roon Arc settings matches the port number being used on your router? We’ve seen a few cases where an ISP or router can change port numbers and therefore break the port forwarding rule.

If possible, as a test, please hardwire your core directly to your router.

We’ll need to confirm this is set into bridge mode. Can you supple the specific model number? We can take a look at the online manual to find out the specific steps for this.

I’m on Virgin and no issues. It will be the port forwarding setting on your Mesh that’s changed. This could be the ip of your Roon core has changed if you have not reserved its DHCP address. Do you have UPnP on the mesh router?You need to ensure that your forwarding port 55002 from the router to the ipaddress of the core.

Err - I switched the router off and restarted it and it now seems to work - v.strange. Good old technical reset.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.