ARC Cannot find Core, even though Ready check is checked

Roon Core Machine

MacOS Monterey 12.6
Late 2014 Mac Mini
8 GB Ram
500 GB SSD
Roon 2.0

Networking Gear & Setup Details

1GB Broadband
wired connection >
10/100T Switch

Connected Audio Devices

both iphones 11, 13and ipad can not connect to core, even though purple check is marked and “Ready” is illuminated in ARC Settings.

Number of Tracks in Library


Description of Issue

both iphones 11, 13and ipad can not connect to core, even though purple check is marked and “Ready” is illuminated in ARC Settings.

Jefferson, sorry to hear about your issues getting ARC to work. I am a fellow user, but if you can supply a bit more information we can work on helping resolve your problem:

  1. Who is your internet service provider?
  2. Please list the make and model of your modem and router?
  3. Do you have any additional network hardware, like additional routers or managed switches?
  4. Does your network have any VPNs, proxy servers, or enterprise-grade security?
  5. How is your Roon Core connected to the internet?

Hello Robert —

Thanks for your offer to help! It took me a moment to gather the info, sorry

  1. ISP is in Northern California

  2. modem is an EERO model B010001

Connects to a netgear gigabyte Ethernet switch model GS605v5

That connects to another GS605v5 via cat 5

That connects to my 2014 Mac Mini via cat 5 cable.

My hardrives are connected to my Mac mini via USB3

  1. no

  2. not that I know of it’s the basic installation from

  3. connected via hardwire via the path above.

Hope this helps please let me know if I can provide any other info.

This is particularly weird considering my core says it’s ready but then I don’t find the core through the ARC app.

Thanks in advance for any help!


Thank you @Jefferson_Douglas. You are not seeing any error message under Settings → ARC, is that correct? Have you confirmed your WiFi settings are correct in your network for iPhone and iPad, and if so, do they connect to the Core within your home over the ARC app? What about the regular iOS app?

Hello Robert —

The opposite. My existing Roon app connects to the core and functions fine. At the core itself, the ARC section has the “ready check” checked.

It’s the iPhone / iPad ARC apps that can’t find the core.

Ofherwise my phone and iPad function wirelessly fine on other applications. (Safari, streaming apps, etc).


Jefferson, do you have the regular (non-ARC) iOS Roon Remote app installed on the iPhone or iPad? If so, do these connect to your Core correcly?

Yes I have the original Roon remote on my iPhone and iPad and that connects to the core without issues. It’s only the ARC App that fails to find the core

Have you tried resetting ARC at the bottom of the ARC Settings menu?

At this point, I can’t access the settings section on either of the ARC apps (iPhone / iPad). I only get to the login screen, enter my credentials and then get logged in, but receive the message “no Roon cores found”

Is your WiFi on your iPhone and iPad? Have tried reinstalling ARC and rebooting the phone and tablet?

Yes, I deleted the app, rebooted my phone, then downloaded ARC again, logged in, and still the core wasn’t found :confused:

Problem solved!!

Please don’t hate me, but apparently I had two Roon logins! When I tried the other account I was able to log into arc and everything is working!

Sorry to drag you through this obvious “operator error” issue, I guess it had been a while since I actually logged in!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.