ARC crashing after use

Roon Core Machine

NUC i3 8GB RAM Running ROCK

Networking Gear & Setup Details

Fritz Box 7530 with Fritz repeater 3000 using Zen internet No VPN

Connected Audio Devices

Number of Tracks in Library


Description of Issue

Arc works perfectly when I download it onto my android phone (RealMe 7 Pro) but once I close it and try to re-open it again it immediately crashes? I have tried force stopping it but this has no effect. I have to delete the app and re-install it every time I wish to use it.

It’s great when it works however, just a shame it’s not working for me.

Hey @Richard_Smith1,

You have my sincerest apologies for the delayed response here, we’ve been dealing with a higher-than-usual volume following our release and we’re working as quickly as we can to get back to everyone.

As a next step, we’ll need to get a set of Android device logs to further investigate. Steps to follow below:

Connect your PC to Android phone and install ADB (instructions are here (all platforms)). Then:

  1. Type adb shell in terminal
  2. Type logcat v (ref: Logcat command-line tool  |  Android Developers)
  3. Reproduce the problem and let terminal print logs for 3-5 more seconds
  4. Select output from the moment you started the reproduction of the bug till the very end
  5. Upload the log here and let us know once you have done so:

I’ll be on standby for your reply :+1:

I’ve sent the log as a word document. Hope that’s what you wanted.

Hey @Richard_Smith1,

A few follow up questions for you:

Are you completely shutting the app down when closing it, or swiping it into the background? If you completely shut the phone down after shutting the app down, does crashing still occur?

Lastly, are any other apps running while you are experiencing this issue with Roon?

Hi Benjamin,

I close the app by pressing the ‘return’ key on my mobile device.

Is there another way to close the app?

There are no other apps running that I’m aware of. Everything else on my mobile runs when use it it and is shut down the same way.

I’ve tried clearing the cache but that doesn’t work.

If I delete the app and then re-install it it works fine for a few times then starts to crash.
If I clear data and log back in it also works but then crashes after I close it down.

Hey @Richard_Smith1,

Here is a short video on what I am referring to with completely closing an app on your phone: How to Close Running Apps in REALME 7i - Background Applications - YouTube

How many free GB do you have left on the internal storage bar found in your arc settings?

Also, if you could please take note of the exact date and time the next time it crashes and share it here, that would be helpful :pray:

Hi Benjamin,

Thanks for getting back to me so quick.
Last night while attempting to resolve the issue I logged into Roon and changed my password as I thought it would be simpler to log out of Arc and log back in to enable me to use the app.
When I logged back in and checked the settings on Roon for Arc, I was getting a message informing me that Arc would not function with my mobile device.
I checked my router settings and it appears that on my initial set up I had used the the IP address for the Wi-Fi connection of my Roon Rock which was no longer available?
My Rock was previously connected via Lan & Wi-Fi.
I changed the IP address and also the Port Forwarding address and logged onto Arc on my mobile device and it seemed to be stable.
I will give it a few days and if there are any more issues I shall contact you.
Thanks for your help Benjamin.
And thanks for the YouTube link.
Incidentally, I have over 30GB of memory available to Arc and no downloads as of yet.


1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.