ARC for Dummies

Roon Core Machine


Networking Gear & Setup Details

Motorola Modem, Netgear Router, Ethernet connection, EtherRegen Switch.

Connected Audio Devices

USB to Rotel Integrated amp with internal DAC

Number of Tracks in Library


Description of Issue

I still can’t seem to connect ARC to Core. When I’m in my house, ARC does play through my iPhone remote. When I’m outside my house or in my car, ARC doesn’t connect to Core. I am fully updated with the latest version of Core. I was previously advised to change my Port Forwarding.

I got into Roon for the music and audio quality. I am hardly IT savvy. I’m actually an IT Dummy. I couldn’t even begin to have an intelligent conversation as to what Port Forwarding even is. When I read the Port Forwarding article in the Roon Support section, the instructions may as well be in a foreign language.

I’m hoping to figure this out without engaging an IT Tech. I would really appreciate easy to implement instructions on this port forwarding issue for an IT Dummy like myself.

@Glenn_Zeleznick, sorry to hear about your issues in getting ARC to work for you. A fellow user here, but I moved this to the Port Forwarding support category so Roon and the community can provide better support.

Could you please provide some additional information in the following areas:

  1. What is the exact message you are receiving in the Roon->Settings->ARC tab, and what port number is referenced there on the bottom right? I believe you can copy the message and paste it here.

  2. What are the specific model numbers of your Motorola modem and Netgear router? These are important because if your Motorola modem can be configured also as a router, the resolution may be different than if it is only a modem.

  3. To confirm, is your Nucleus connected via an Ethernet cable to the Netgear router?

  4. Who is your ISP?

There may be other questions, but these should help us get a better view into what you are experiencing.

My Motorola DOCSIS 3.1 modem model is MB8600, The Netgear router model is R6400. It’s connected to my Ether Regen switch via Ethernet, which is then connected via USB to my DAC. My ISP is Cox Cable.

Here’s the message I receive when I open the ARC tab in Roon Sttings:

} {
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}

A post was split to a new topic: Roon ARC Setup on ASUS Router

Thanks, this is helpful. Have you tried activating UPnP on your Netgear router? This is one method Roon uses to get ARC to connect your home network to your mobile network. I am not familiar with the Netgear administration, but there should be online help available here or via Google to demonstrate how to activate it. If that does not work, then the port forwarding option remains a possibility.

Hi @Glenn_Zeleznick,

Do you still have issues with Roon Arc? If so, I would suggest you create a manual port forwarding.

First in the Roon app under settings —> Roon Arc write down the ip address and port number.

Please watch below video, it’s not your exact model, but I think it should be enough.

Let me know if it helps.

Kind regards,


1 Like

Hey @Glenn_Zeleznick,

I wanted to check in on this thread to see if you were still running into issues getting Arc setup? You have some excellent next steps on this thread to try out if so :+1:

Thanks for checking back in. I’m just a little hesitant to delve into something that I’m completely unfamiliar with.

Hey @Glenn_Zeleznick,

I understand! It can certainly feel like a daunting task. Perhaps if you wanted to take a look at the video @Maarten_Duits included above to see if it’s something you’d be interested in digging into deeper, that may help.

I’ll leave this thread open for now in case you’d like to revisit :+1:

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.