Arc have connection issue under LAN

Roon Core Machine

Silent Angel Z1

Networking Gear & Setup Details

CERNET, The China Education and Research Network
with redmi AX6000

Connected Audio Devices

Number of Tracks in Library

278 albums

Description of Issue

In the previously version, Arc works fine under LAN, after latest updated in the Roon( 2.0.11 ) and ARC(1.0.32), always notified me 「bad connection」.
I can’t fix 「code 998, MultipleNat」 issue by change my ISP from CERNET to let Arc work properly.
All I’m want is download my music under Lan, so I can play local music by Arc in the phone.

Hey @Lei_Qiu,

You have my sincerest apologies for the long delay in following up on your issue. I wanted to check in and see if you were still having Arc issues?

The diagnostics you’ve provided suggest there is a redundant layer of network address translation preventing port forwarding.

This can either be at the local-network level (commonly as a result of two routers), or at the level of your service provider (in the form of carrier-grade NAT).

If your setup involves an ISP-provided gateway (modem/router combination) and your own third-party router:

  • In the web administration interface of the ISP-provided gateway (modem/router combination), enable Bridge Mode or equivalent, where the ISP-provided gateway does not have DHCP routing enabled.

  • Alternatively, if you have already created a manual port forwarding rule in your 3rd party router, you can add an additional rule to forward the port through the ISP/second router.

If you only have one router in your setup or your modem is already in Bridge mode, please take a look through our list of known router and internet service provider solutions, as other users may have already encountered the same situation: ISPs and Routers: List of Known Solutions and Workarounds

You can reach out directly to your service provider to ask if they support port forwarding; this question will often enough to prompt them to explain whether or not the carrier-grade NAT they’ve implemented can function with ARC.

More specifically, you can pass along the following questions:

  • Have you implemented carrier-grade NAT for my account level?
  • Have you fully implemented IPv6, or do you have IPv4 addresses available?
  • Can I request a static IPv4 address to support port forwarding?
  • Are there any ports you have reserved at the ISP level I should be aware of?

If you’re unable to locate an existing solution in our #support:port-forwarding-resources subcategory, please reach out to the Roon support team and include the following information:

  1. What is the make and model of your modem and router?
  2. Do you have any additional network hardware, like additional routers or managed switches?
  3. Who is your internet service provider and what is your geographic region?
  4. Is your Modem configured in Bridge Mode so that it operates only as a modem or do you have the ports forwarded on both?

Hi Benjamin,
Thank you for reply.
This issue has already solved, turns out all I need is log out and reconnect to my Roon core.
My network were operated by my university, kind of difficult to change modem setting, to make Arc working properly, I probably needs change to another ISP.
but anyway, thanks for helping.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.