ARC is not working on my mobile network but works on WiFi

ARC appears to be correctly configured.

I can connect using ARC with my mobile phone within my local network using WIFI but cannot connect using the mobile network even when I have 200 Mbps symmetrical bandwidth.

Please help me solve it.

Thank You,
Marin Rene

Please fill out the information that is requested for new posts in #support:port-forwarding-help but that you may not have seen if your post was moved here. You can copy it and post it into a new reply:

Roon Core Machine

<!-- Include your operating system and machine info (Model, CPU, RAM) →
<!-- Write below this line →

Networking Gear & Setup Details

<!-- Your network gear (model of routers/switches), if on WiFi/Ethernet, and if you are using a VPN–>
<!-- Write below this line →

  1. Who is your internet service provider?

  2. Please list the make and model of your modem and router?

  3. Do you have any additional network hardware, like additional routers or managed switches?

  4. Does your network have any VPNs, proxy servers, or enterprise-grade security?

Connected Audio Devices

<!-- Specify what devices you’re using and their connection types, like USB/HDMI/Chromecast, etc.) →
<!-- Write below this line →

Description of Issue -

What is the exact port forwarding error message you see in the Roon Settings → ARC tab?
<!–Tell us about the problem you’re having in as much detail as possible. Screenshots are always appreciated! →
<!–Write below this line–>

Operating system
Windows 10 Pro 64-bit Version: 19045.3324
System memory
8 GB

ROON ARC says everything is fine.

I can connect my mobile phone to ROON ARC using the WIFI network but not using the cellular Network

Hope this is enough information and you will be able to help me.

Thank You

-Marin Rene.

OK thanks. On more piece of information: what is your internet provider?

And can you try something?

  • Visit Port Checker - Check Open Ports Online with a browser while you are on the wifi
  • It should automatically detect the external IP address of your router in the “Domain/IP” field
  • Enter the port number 55002 that ARC is using in the “Ports” field
  • Click the Check button

What is the result? It should show as “open” and we want to know if it does

1 Like

First of all I would like to Thank You for your kind help.


And I have performed the check as you instructed me directly on the ROON Server.

The result is below

May I kindly ask you for a suggestion to solve it?

Thank You again.

-Marin Rene

Glad if I can help, I appreciate the kind words :slight_smile:

OK, this is not great. It is possible (likely) that something in your ISP’s network is blocking access to the port, and does so in a way that Roon cannot notice (hence why it says “Ready”). I had something similar with Vodafone in Germany. It took me a lot of convincing on phone support to explain to them that this is not how it is supposed to work.

I also note that you have an IPv6 address (the new version of IP addressing). This is normal with TOTALPLAY, they don’t seem to provide IPv4 addresses anymore for residential accounts. Roon added support for IPv6 to ARC in May of 2023, so it is possible that this can be made to work. However, we have seen that there are still issues with some IPv6-only ISPs in some cases. My own experience with IPv6 is limited, though.

Therefore, I am paging @connor from Roon support to look into this. Connor, you investigated TOTALPLAY in January in this post and found out that they are IPv6-only. At the time, this was before IPv6 support was added to Roon.

1 Like

Hi @MarinRene,

We’d be happy to illuminate some possible resolutions here, although TotalPlay’s interaction with ARC is, as others have mentioned above, relatively new ground for this forum.

IPv6 doesn’t rely on port forwarding, but there’s a similar process involving your router’s IPv6 firewall.

In the settings for your Huawei router, I’d try the following:

  1. In Security settings or similar, look for anything related to IPv6 firewalls. Sometimes it’s called IPv6 pinholing. It should be a list of IPv6-format addresses that the firewall allows to go through to the internet. You will need to add the Roon Core IPv6 address from Roon → Settings → ARC to this list.

  2. If step 1) above doesn’t work or isn’t available, then look for a tab in the router settings called “IPv6” or similar. There should be settings related to DHCPv6 Prefix Delegation. Turn these on.

  3. If step 2) above also fails, then please contact TotalPlay and inquire if they have DHCPv6 prefix delegation.

Even with the simplicity of IPv6, your ISP may be preventing Roon from opening a channel to ARC through their own machinations.

We’ll support you as you go. Thanks for reaching out.


Hi Connor,

Sorry for not answer your kind message before, I was out of town.

I am afraid there is no settings on the router (it is a Huawei HG145V5) that might appear useful to perform any of your suggestions.

Allow me to send you the screenshot of what the router shows.

Is there something you can suggest to me?

Is there nothing under Security and Forwarding sections as that’s for DHCP management which is very different.

1 Like

Hi @MarinRene,

Please share a screenshot of the Security tab, with any IP addresses or sensitive information omitted. We’ll need to see if an IPv6 pinhole is available.

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.