ARC: Large Playlist Download Contained Corrupt Tracks (Can Reproduce Irregularly)

Tried downloading a big playlist. Some of the tracks are badly corrupted. They play essentially white noise at full volume after a few seconds. Deleted those downloads and re-downloaded. Same problem, different tracks. These tracks are mostly 96/24 format although there are some corrupted CD quality.

Should really be an option to transcode downloads. Should also be an option to re-download individual tracks if they’re corrupted.

Hi @Andy_Jones,

Thank you for the report. The tech support team will have a look into logs from the backend.

If you don’t mind, would you clarify the following to help our investigation?

  1. What was your connection when you downloaded the playlist initially? Were you on cellular, guest Wi-Fi, or your home Wi-Fi connection? Were there any connectivity symptoms or error messages outside of the corrupt playback?

  2. Can you please specify a few example tracks from the playlist that first exhibited the corruption? An approximate timestamp of when you attempted the download works as well if you don’t remember the exact tracks.

  3. Which Core device was ARC connecting to during your report?

We’ll report back here once we have a look through diagnostics, etc. Just in case, if you still have some of the corrupted tracks downloaded in ARC, don’t delete them quite yet. They may be useful for the team to examine.

I appreciate your patience @Andy_Jones! I assume no other issues with streaming or local playback?

Connection was home wifi to the NUC core. That might have changed to cellular at some point during the download. It’s the second time in 24hrs I’ve tried to download this playlist, I’m not sure at what time the corrupted tracks were downloading but they were different tracks at different times in the 2 different attempts. I’ve already deleted the downloads.

Tracks that corrupted were roughly from Peace in the Valley - Elvis to Piece of My Heart - Big Brother etc.

They were probably downloading late morning GMT.

Streaming is not working for me as I’m behind a CGNAT. Local playback on the phone has been patchy in places. Loss of response from the app while downloading etc.

I also have the above. I downloaded a personal playlist and now notice that I have a garbled file in this list. It’s a song from the Eagles (Hotel California). It is a 192/24 file which restarts again halfway (at 2:54) through the song.

By the way, I have the playlist via my home network (Wi-Fi) to an iPhone 11. And for your information (for what it’s worth), I’m using an Intel NUC.

Good to know I’m not alone in this. The corrupted tracks also had a repeat at the start of the first few seconds in some cases. Then ear splitting white noise which will be a wake up call to anyone playing tracks on a big system!

I have successfully downloaded the large playlist and skipped through every track to check it’s not just white noise. There could still be issues, it’s a 17 hour playlist but it is now much more as I would have expected it.

What I did differently. I left the phone playing the playlist while downloading. I did nothing with any other instance of Roon. I didn’t fiddle with network settings or try remote connections during the download. So in ideal circumstances it was successful. With a broken (CGNAT) remote connection it may have created problems.

What I see now from ARC I like, I wish I didn’t have the CGNAT problem but that’s my issue to sort out. Other wise I do like the look of ARC and I appreciate having playlists on my phone that I’ve created with Roon. I look forward to the day when I will be able to enjoy the full package.