ARC not playing nicely with Nucleus+ and OrbiRBR850 w/1 satellite

Roon Core Machine

Networking Gear & Setup Details Nucleus+, ORBIRBR850 w/1 Satellite over Ethernet.

No.
  1. Who is your internet service provider? Spectrum

  2. Please list the make and model of your modem and router? DOCSIS 3.1 Modem; ORBI RBR850 w/1 Satellite

  3. Do you have any additional network hardware, like additional routers or managed switches? No managed switches, but three unmanaged ones.

  4. Does your network have any VPNs, proxy servers, or enterprise-grade security? No.

Connected Audio Devices

Everything is playing over Airplay(2, presumably). Two streaming speakers, (Bose soundbar, Oppo streaming speaker), one Oppo Network Streaming DAC connected to primary sound system.

Description of Issue -

What is the exact port forwarding error message you see in the Roon Settings → ARC tab?

{"connectivity": {"status":"NetworkError","status_code":502,"error":"error: Error: connect EHOSTUNREACH 76.aaa.bbb.ccc:55002, response code: undefined, body: undefined"},
"external_ip": {"actual_external_ip":"76.aaa.bbb.ccc","actual_external_ipv6":"2603:8000:d800:12c7:56b2:3ff:fef0:e7fb","router_external_ip":"null"},
"natpmp_autoconfig": {"status":"NotFound"},
"upnp_autoconfig": {"server_ip":"192.168.1.1","found_upnp":true,"error":"<s:Envelope xmlns:s=\"http://schemas.xmlsoap.org/soap/envelope/\" s:encodingStyle=\"http://schemas.xmlsoap.org/soap/encoding/\"><s:Body><s:Fault><faultcode>s:Client</faultcode><faultstring>UPnPError</faultstring><detail><UPnPError xmlns=\"urn:schemas-upnp-org:control-1-0\"><errorCode>501</errorCode><errorDescription>ActionFailed</errorDescription></UPnPError></detail></s:Fault></s:Body></s:Envelope>"}
}
For lack of a better word, the connection appears to be unstable. One day, Roon indicates that its connection with ARC is ready; then, when I actually intend to travel someplace, nothing, usually, happens and I am faced with a "no connection" message. It has worked a couple of times, but, that is rare.

The diagnostics you’ve provided suggest that UPnP is enabled on your network, but your router is refusing the connection. This is either the result of UPnP not being enabled properly on your router, or settings at the level of your internet service provider.

First, to confirm the issue is not with your local network setup:

  • Try to enable UPnP/NATPMP in the web administration interface for the router directly upstream from your Core
  • Try to manually open the port in your router’s port forwarding configuration
  • Make sure the IP/Port matches the Port listed in Roon → Settings → ARC
  • Check for any VPNs or Firewalls that might be interfering
  • Check if your modem is in Bridge mode

If you continue to experience difficulties, we recommend reaching out to your internet service provider and passing along the following questions:

  • Have you implemented carrier-grade NAT for my account level?
  • Have you fully implemented IPv6, or do you have IPv4 addresses available?
  • Can I request a static IPv4 address to support port forwarding?
  • Are there any ports you have reserved at the ISP level I should be aware of?
1 Like

Had the same issue with my Netgear Orbi. The solution was to provide the core with a static IP address. Also manually open the port 55000 on the Orbi. That fixed all my ARC connection issues. I think what’s happening is the Orbi isn’t letting ARC know when the IP address of the core changes. So the core looks like it’s ready (and it is), but ARC can’t find it.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.