ARC not working at all

Been messing with the network setup for a while now and it won’t work.

Is this a waste of time, as I can see that my internal WAN address in the router is not identical to the WAN IP I get on e.g.

Does ARC only work with static IP?

Skærmbillede 2022-09-21 kl. 21.06.01

Skærmbillede 2022-09-21 kl. 21.06.12

Roon gives me this error message
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}

UPNP is disabled and manual port forwarding is set up

You are using 2 public ip addresses.

In general internal IP addresses are found in (RFC 1918):

inetnum: -
netname: DK-SEAS-NVE-20011212
country: DK
admin-c: SN1451-RIPE
tech-c: SN1451-RIPE

  1. the missing PTR should ideally be provisioned
  2. upnp generally won’t send to an external IP. not that I know but hopefully will be corrected if I am wrong.
  3. I am using here, as I bet most will be, a dynamic IP.

Please fill out the network/hardware template to let us know more specifics. I’d like to hear you’re listening to music.

But I can’t control which ip addresses my ISP uses, and they apparently use CGNAT.

I use 2 Linksys MX4200 for a MESH network.
Connected to Fiber optic 1000/1000

Roon Core is running on a MacBook Air M1.

You might be able to request a static ip from them.

1 Like

And so back to the main question.

Does ARC only work with static IP, and not with CGNAT?

A static IP address costs extra with my ISP.

CGNAT shares an IP address with multiple customers, so Roon ARC is unable to connect to your core. The solution is to upgrade to a fixed IP address.

1 Like

No ARC for me then…

That is seriously unfortunate. I hope you let them know their way of NATing is causing problems. Their dev team can follow your setup easily to confirm. But, someone will need to let them know.

3 posts were split to a new topic: Setting up ARC (possible CGNAT)

maybe you can set a fix IP with the Router for the Roon Core
I have PPOP from the internet provider and I set a fix ip for the core inside the router app
Arc is not working for me jet, synchronize issues with the Core, I didn’t had a chance to try it outside the netwoork

Got my ISP to change from CGNAT to public IP, and then it worked.
No need for fixed IP, apparently just a public IP.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.