ARC not working with Pixel 6 phone

Roon Core Machine

Windows 11, Intel i5, 8 gigs ram

Networking Gear & Setup Details

Bell Homehub 3000, ethernet, no VPN

Connected Audio Devices

Number of Tracks in Library

5000 tracks

Description of Issue

I cannot make ARC work with my Google Pixel 6 phone. it says “searching for Roon core”. Core is working fine with ARC on a forwarded port. The conventional Roon app on my Pixel connects to the core. ARC installed on my wife’s Samsung Galaxy connects, as well as on my iPad and Fire tablets with ARC installed. Only the Pixel 6 is problematic. I have tried changing the forwarded port in the ARC core configuration 55000, 55002 etc., but ARC on the Pixel 6 fails while other ARC installations continue to work fine.
The Pixel 6 is the device I really want to use with ARC, so this is a little annoying.
Any ideas or tips for getting this working would be appreciated. There are no VPNs or unusual Pixel 6 configurations involved that I am aware of, but the issue seems to be confined to that device.
Thanks.

I have solved my problem. Perhaps my experience will help other Pixel 6 owners.
I nosed around in the Pixel settings and realized that, because I travel with this phone, the time zone setting was incorrect. However, I had set the time manually, so the actual time was correct. In my case, the time zone should have been Eastern, but it was set for Brazil, where I live most of the time. I then set both the time zone and time to automatic (something I don’t normally do because automatic doesn’t work with my cellular provider in Brazil. It does work with my provider in Canada, where I am at the moment).
After doing this, voila. The Arc app started, connected with the core, and a few minutes later when the data update was finished everything was working.
So, in a nutshell, it looks like the incorrect time zone was the problem that was preventing Arc on my Pixel 6 from connecting.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.