ARC Playback default conversion to 48kHz

Roon Core Machine

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

Hi,

When using ARC it seems to convert from whatever sample rate to 48kHz.
I’ve using a Sony Android phone via cable into a Hugo 2.
I can see in the signal path that it’s a DSP setting, is this something I should be able to change?

When using Qobuz directly it outputs correctly i.e. volume is controlled by DAC and the correct sample rate is showing.

Thanks
Dan

In your ARC playback settings toggle off Automatically pick best quality and you’ll see options to set playback quality for wifi and cellular.
Set this to Original Format and it should stop downsampling.

Android Audio always resamples music to 48 kHz. Since Roon can do a better job, it does the resampling.

The point is that I do not want it resampled. I want the single pure, like it would be on my main system.


You can see that it’s coming through at 96 but then it’s down sampling it. I’ve got it set on the highest quality setting already.

Then buy an iPhone; resampling is a limitation of Android Audio.

1 Like

That’s not a very helpful response. It also isn’t the case as Qobuz will output at 96 quite happily as will Audio Player Pro.
If Roon doesn’t have that option then please just say that, don’t blame it on other things.

I thought you had an external DAC connected.
Yes, this is an Android thing.
My Android based DAP supports HiRes but some apps, including ARC, downsample to 48khz.
If I connect an external DAC to the DAP I get full resolution with ARC.
My iPhone gives full res without an external DAC.

Roon has said in another thread full res support for Android devices is forthcoming (or may be forthcoming, I can’t recall)

1 Like

iPhone will downsample to 24/48 without an attached DAC. With a DAC, it can play Roon ARC at up to 24/192. I set Roon ARC at “Original Format” over WIFI and “CD Quality” over cellular.

1 Like

Android limits audio by default. It is possible to write applications that directly address the hardware and play back bit perfect.

Getting each company to write to that standard takes hours and people.

source.android.com/docs/core/audio/highres-effects

Shanling plays Bit perfect under their app on android 10.

It would be great to see. I am tempering my expectations though. Maybe Astell & Kern can kick back code since they are/were supported and partnerships go two ways?

I end my ramblings. Thank you.

1 Like

Yep, I have my Hugo2 attached via a cable. That’s my whole point. I don’t understand why it’s down sampling. Exactly the same connection using Qobuz works correctly. Nice blue light on the Hugo.

1 Like

I was mistaken about iPhone.
It is also 48khz without an external DAC.
Apologies.

However I just tried to test my Android DAP with an external DAC.
I haven’t used ARC in about a week.
I had to log in to Roon again.
It told me my core was not configured for access beyond my local network (I was using it on cellular before)
AND I’m also now getting downsampling to 48khz despite being set to Original quality and volume levelling off.

1 Like

Unfortunately Android automatically samples everything to 48khz.

Sadly the only way to get bit perfect from a phone is an iPhone or iPad. Or use the UAP Pro android app with a DAC.

This is a big for all is Android users.

This is all pretty strange.
Despite ARC telling me it’s not configured for outside access it works when not on LAN.

Also my signal path on iPhone has some weird info under Sample Rate Conversion.
I’m wondering if there’s been an update to ARC that is buggy?

This is what I see when playing a 24/96 on iPhone without a DAC attached and with WIFI set to “Original Format.” Maybe you’re using DSP in Roon that you see in ARC.

I’m a community member, just like you, and I already explained that this a consequence of Android Audio. This affects connected DACs, too.

If you want Roon ARC to output higher sample rates, you’ll need an iPhone.

Some apps bypass AA, but Roon doesn’t.

3 Likes

In your snip it is converting it to 48 isn’t it?

I do normally use my iPhone as a remote and with DSP.
I just turned off the DSP in Roon but still get the odd Sample Rate display in ARC.
But this is straying off topic.

Based on other responses here I’m thinking I may have been mistaken in stating I was getting full res from ARC with an Android device with an external DAC.
I bought a new DAC and a new Android music app about the same time ARC was released.
I seem to have confused myself.
Apologies for befuddling things.

2 Likes

The output is the iPhone speaker; a connected DAC will see 96 kHz.

Yes, iPhones do 48 without an external DAC. I already said that.