Arc poor connection problem

Roon Core Machine

Ubuntu 22.04.1 LTS
Manufacturer: ASUSTeK COMPUTER INC. Product Name: E35M1-I
AMD E-350 Processor
8GB memory

Networking Gear & Setup Details

Ubiquiti Dream router. Roon opening Arc port via upnp

Connected Audio Devices

NAD M33
Bluesound PowerNode N330

Number of Tracks in Library

11274

Description of Issue

I have problems using Arc on Android 12 (On OnePlus 10 Pro)

When I choose to play something it takes a long time and I would always eventually get the “Poor connection” message

Arc settings when using roon remote tells me all is ok. And I can connect just fine from the Arc app over 5g

I made a test yesterday. Choosing a track in AAC format streamed fine while choosing a track in flac format (most of my library) only results in the “poor connection” message

So it seems the problems has something to do with transcoding flac to the format you automatically choose for Arc (is it 320bps MP3?..I don’t remember)

While my room core is not the fastest it can transcode flac to 320bps mp3 with 11x realtime speed. So I really don’t understand why it shouldn’t be fast enough for Arc

Hope we can get this solved so I can be as happy an Arc user as I am a roon user

BR
Hasse

Just tried again setting the quality when on cellular to original format. No problems on 5g with that(but that will be a little data intensive in the long run)

So I think there is something wrong the way you do transcoding(i could transcode a flac file to mp3 with lame in about 11x realtime). So something is definitely wrong with the way you transcode. Are you deciding the whole flac file before transcoding or something?