ARC - poor connection [SOLVED]

Hello, is there any trick to avoid poor connection?

Pic 1 - HOME-Roon-arc-ready test


Pic 2 - iPhone -Error message - schlechte Verbindung (german) → poor connection (english)

2 Likes

I had this issue frequently over the past few days on my Android phone. Uninstalling and reinstalling the Roon Arc App fixed it for me.

5 Likes

I had similar, i had to undo and redo the router configuration step.

1 Like

Whats the upload speed from your home and is it stable?

I had the poor connection error at home on my wi-fi as well.

85/15 fibre
Very stable

After reinstallation of the APP
App starts first synchronisation which takes hours with a never ending dead circle

I will do this when i am at home

this means your roon arc upload out to the iphone is going be max 15mbps and ths damn slow even with nothing else happening on your network

1 Like

This is correct
15 MBit/s

What speed is necessary?

Higher than what you have for sure it seems. what quality are your settings showing? maybe use the lowest data speed settings like Bandwidth Optimized

what does a speedtest actually show from your core location as upload available to say your iphone carrier servers?

Meanwhile - it is working fine.
It took more than 3 hours of synchronisation with roon-core

Remove of ARC app and new installation and waiting for synchonisation solved the problem.
Thank you for the help :+1::grinning:

1 Like

It will depend on the streaming source. Assuming you’re using your own files then the 15mbps is in play. If you are streaming from tidal or Qobuz services these bypass the Roon core.

Everything depends on the coverage your phone has ultimately and the slowest link in the chain

If you download while at home then play downloaded content it shouldn’t matter at all

2 Likes

A stereo 24/192 FLAC file is about 5 Mbps, CD quality is less than 1 Mbps. 15 up should be just fine unless using 24/192 and/or something else is using lots of outbound bandwidth.

If 15 wasn’t enough, ARC would be dead in the water because the vast majority of internet connections are asymmetrical. I had to purchase 300 down to get 30 up.

And the poor connection generally seems to be about the cell connection more than the Core.

1 Like

You also have to consider the many network nodes that cause propagation and thus make transmissions less efficient especially with cellular data.

Yes. From your link:

Some music streaming services like Apple Music and Tidal offer high-definition “lossless” audio, however. These streams can reach just over 9 megabits per second (Mbps). You’ll need an internet plan that’s at least 20 Mbps to handle these streams.

I don’t know where they get 9 Mbps from. 24x192,000x2 is 9.2 Mbps, at 50% FLAC compression that’s about 5.

Add some crazy overhead and let’s accept 9 Mbps then. That doesn’t make 15 Mbps up from the core “damn slow”. And streaming 24/192 to a Bluetooth device is crazy anyway, 1 or 2 Mbps for CD quality is much more realistic.

But we agree on what you wrote later, the bottleneck is usually going to be the phone’s cell connection

I’ve also sometimes this problem.
Reinstalling the app will not solve it completely (only temporarily).
Also the discussion about the bandwith fits not to the issue, because the message will not popup while playing, but when you’ll get the metadata from the Roon core.
There seems to be an parameter in the app, which defines something like a timeout and fullfilling it, the message appear.
I’ll think, you can produce this issue in changing a lot (add or delete many music files) on the core and start the Roon ARC with a slower connection.

I found moving from one network to another caused lost connectivity to the core sometimes. For example moving from 4G on the road to WiFi at a hotel caused a lost connection for a while for me, after some time, I don’t know, maybe 30 minutes to some hours, it reconnected. Not sure if this is something related to the port forwarding and the change of source IP address of the phone or something, who knows.

I saw this for the first time a few days ago while fiddling around with ARC in my home network in Canada. There was no outside transmission involved, but for the record my internet speed is 1.5 gigs. So I tested internal speeds on the ARC wifi device. Tested at 700 megs. This appeared only after a few error-free weeks with ARC, and I changed nothing in the network.
I have since travelled from that home in Canada to my other home in Brasil and set up ARC there for the first time. Using it internally I am seeing this message again. Internet speed, which should be irrelevant unless I am using ARC away from home, is 500 megs. Internal wi-fi to the device using ARC tests at around 550 megs in this home.
There is nothing “slow” about the networks in either home, so I am assuming this message is erroneous.

I had the same problem with my iPhone. Unintalling and reinstalling the app fixed the problem for me too.

2 Likes