ARC port assignment not persistent

Roon Core Machine

Windows 11 Laptop, i7, 32GB RAM

Networking Gear & Setup Details

McAfee Firewall → Netgear GS108 switch → Google Nest Router (Mesh)

Connected Audio Devices

Buchardt A500 via chromecast inside

Number of Tracks in Library


Description of Issue

I upgraded my core and remotes to 2.0 immediately the new version was available. This required me to manually port forward “55002” on both the google nest router and the McAfee firewall on the Windows laptop. I can sympathise with those frustrated roon users still struggling to get ARC working as I would fall into the category of those with virtually no home networking knowledge. Anyway I spent the best part of an afternoon on YouTube and the forum and finally got it working (on my home network).

I do not know if this is a coincidence but this morning I transferred a large queue from my “system out” endpoint to a remote chromecast endpoint. I then checked my ARC config as we are going on a trip and I was planning on testing ARC out of the house. But then I get an error message on the roon ARC config page saying that another device is using port “55002”. Annoying but not fatal. I got ARC working again by re-assigning port “55000” on:

  1. The roon ARC config page
  2. The google nest router
  3. The MacAfee Firewall

There were certainly no surprises about my port assignments on either google or McAfee. They hadn’t changed, they were still “55002”. So my question is, why was the roon port assignment of “55002” not persistent? Any ideas?

Are you using UPNP for the assignment, if so change it to a manual port.

Mine has been up and running since July and has never once changed port number. Roon was just telling you that something else was already bound to that port so picked another port.

Ah. Ok. I just have no home networking knowledge so that hasn’t occurred to me.

I actually had UPnP switched on already for some other service and that maybe was the reason I couldn’t get ARC working without a manual config in the first place. Of course I cannot remember what that other service(s) is/are. So when I switch UPnP off, presumably that other service(s) will not work or there will be some other conflict?

If this is the reason then I would have thought at scale, many using roon on a non-dedicated device are going to be affected. Ironically, the reason I have roon core on a laptop is that was my mobility solution in the absence of ARC.

Anyway. I will switch off UPnP and report back my experience.

1 Like

Tony, while we have all worked through a long beta process, this port forwarding along with complicated set-up and ISPs offering CGNAT was a concern for a lot of us.

I have always recommended turning off UPNP myself as it allows software to advertise itself as a service in your home without your knowledge.

Good luck with that, and at least Roon should work reliably for you then.

There are reports of unexpected interactions between port forwarding and UPnP arising on other threads. There are man possible combinations of UPnP on/off on your ISP router, your internal router and your port forwarding rules.

Hey @tripleCrotchet,

Ben here with the support team, thanks for taking the time to write in, and my apologies for the delay in following up.

I wanted to check in on this thread to see if you were still having some issues with Arc and port forwarding?

I’ll be on standby for your reply :+1:

Thanks for responding @benjamin.

I don’t really have an answer for you as after the excitement of the launch I am not using Arc. My primary Arc use case is long motorway journey’s in the car but that is usually with my wife. She will tolerate roon at home but will not allow it in the car.

The initial post was because I found that after a few days I had to reset the port I had forwarded on my router to match a change in port in the roon Arc settings screen. I had not changed the roon settings so the suspect was some kind of conflict between running both UPnP and manual port forwarding concurrently. At the moment I have both UPnP and manual port forwarding set and roon says its “ready”. I have no idea if Arc will work whilst I am out and about but I also have no plans to use it.

TBH my primary mobility use case is not Arc but classic roon between the main house and the summer house. So I just have roon core on my work windows laptop. I have mapped all network data sources at both locations with a core library on the laptop itself. Windows automatically connects/reconnects networked data sources it can see depending on location. I have a lot of Qobuz in my library as well that of course shows up at both locations. As I am the only roon user in the household this works just fine for me although I have long-standing meta-data issues going back 5 years in some cases. I would fall into the category of roon user that would prefer that past loose ends were closed off before new functionality was introduced for which I probably don’t have a use case.

PS: Spoke too soon. It’s about 15 minutes after my original post. I had left the Arc settings page open and I now notice Arc “is not ready”. I can confirm that if I switch UPnP off and leave manual port forwarding on then the Arc status will flip to “ready”. So, at least in my case there does seem to be a conflict. I am using a google mesh wifi network (at this location) in the home and a Danish fibre operator called “Sofa” for internet. At the other location I am using an Icotera mesh wifi network in the home and another Danish fibre supplier “Fibia” for internet.

If you are not using UPnP best set the port for ARC manually on the core. You can choose a specic port number you want to use as long as its in the minimum/maximum range Roon will look for. Then set port forwarding to the port number you set. If you never set it manaully in Roon to start with ARC will automatically configure what port is avalable arounfd 55000 range so will change if their is another serivce clashing with it, which seems to have been the case here. Also if your router has the ability to assign a fixed or reserved ip address for devices I would do so for your core.

1 Like

Thanks for taking the time to post.

What has happened is UPnP is being used by another service but I had forgotten because it would have been installed a very long time a go. I do not use a dedicated core, just my workaday laptop that I use for everything else. I can get Arc working in this scenario by switching off UPnP but that just breaks something else. It is not a problem for me personally as I won’t be using Arc so I have switched UPnP back on. Others reading this that are in a similar situation that do want to use Arc may find the posts useful.

1 Like

UPnP can be used for multiple apps at same time one app doesn’t hog it but if two apps are set it connect on the same port conflicts arise and one will win over the other. Only one app can be open on any one port. This happens in other apps not just Roon. What I was saying is you can set a different port in Roon to its standard one so the issue would then go away.

Thanks. No doubt you are right. I am also one of the Android 12 users experiencing difficulties. Arc is not of any real interest to me whilst the other service is so I won’t be spending any more time trying to get both services working. I have marked this as solved so @benjamin you can close the thread.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.