ARC port forwarding with nucleus

Roon Core Machine

NUCLEUS MacBookPro 2,7 GHz Intel Core i7 quatre cœurs 16 Go RAM

Networking Gear & Setup Details

Modem Technicolor CGA4233VOO connect with ethernet and no VPN

Connected Audio Devices

Amplifier GATO-AUDIO 400 connect by ethernet

Number of Tracks in Library

500 tracks

Description of Issue

Hello, I have started the procedure for Roon ARC in the desktop application. Unfortunately, I have an error message: {
“ipv4_connectivity”: {“status”: “NetworkError”, “status_code”:504, “error”: “error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”: “”, “actual_external_ipv6”: “null”, “router_external_ip”: “null”},
“natpmp_autoconfig”: {“status”: “NotFound”},
“upnp_autoconfig”: {“status”: “NotFound”}
My private network is on an AirPort Extreme terminal, it is the one that gives the DHCP addresses. The terminal is connected to the Modem via ethernet. My CORE is a Nucleus.
I checked that my modem had the UPNP function enabled. In the Airport Utility interface, in the “network” menu, the router mode is configured for DHCP and NAT. I noted the iPv4 DHCP address and the MAC address of the Nucleus. However, with the port settings tab, there are many options and I don’t know what to fill in.

And finally, do I have to configure anything on the modem besides the UPNP function?

Thank you for your help.

@Claude_Geens, welcome to the Community. It appears your Technicolor cable modem also is a gateway router, so you have two routers in your network, which can confuse how ARC communicates outside your network.

Is it possible to activate Bridge Mode in your Technicolor gateway? This way this serves only as a modem and your AirPort Extreme controls all routing across and into/out of your network, as well as assigning IP addresses. I don’t know what is connected to your Technicolor gateway, and this may not be an option depending how your ISP configured it.

An alternate approach if your modem’s Bridge Mode cannot be activated is to create a set of port forwarding rules on the modem and on your Apple AirPort Extreme router using the following guidelines:

  1. One port forwarding rule from the cable modem/gateway to the IP address of the AirPort Extreme router using the port number found in Settings → Roon ARC

  2. A second port forwarding rule from the AirPort Extreme router to the IP address of the Nucleus you use for your Roon Core, using the port number found in Settings → Roon ARC

UPnP should be deactivated on both the modem and the AirPort Extreme router.

Does this help?

Hello Robert,
Thank you for your quick reply and the solutions you proposed. I can indeed switch the modem to bridge mode, but I have to check with my ISP if this does not pose a security problem. I will ask the technical department on Monday and I will let you know what happens.
Good luck and have a good weekend.

1 Like

I put my modem in bridge mode and re-run the test for the ARC connection in ROON, but the error message is the same as in my first message. So I reserved the IP address of the Nucleus in the Airport Utility application, but same result. I tried to do a port setting but the terminal update gives me an error message and I have to restart the application to find my terminal. I have tried in ipv4 mode and in ipv6 mode, same result. I’m quite disappointed, I can’t find anything on the internet to configure my terminal. If anyone has a solution, I would be grateful.
I’m looking forward to hearing from you.

I found this on using an AirPort Extreme with ARC:

If this does not help, I am unsure what to do next. Unfortunately Roon advises against the use of Apple routing products:

Have you tried setting up port forwarding on both routers per my guidance rather than placing the Technicolor modem in Bridge Mode?

No I didn’t tried setting up port forwarding before switching to bridge mode. May be I will try later but I can do without ARC, I wanted to try and see. Thank you very much for your help, even if it didn’t solve my problem. I wish you a very good day.

1 Like

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.