[How To] - Roon ARC and Apple AirPort Extreme router

Roon Core Machine

Roon Nucleus, version 2.0 (build 1128)

Networking Gear & Setup Details

Apple AirPort Extreme router, last model made. Nucleus connected by Ethernet.

Connected Audio Devices

Number of Tracks in Library

Description of Issue

Looking to use Roon ARC and get the following message:

{
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“xxxx”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}
}

As Apple does not use UPnP, I’m looking for help in setting up port forwarding. I believe I have the proper settings in the DHCP Reservations window (MAC address, IPv4 address), but am unsure how to set up the Port Setting window. Here are the fields of the window in question.

Firewall Entry Type: IPv4 Port Mapping (other choice in the drop down is IPv6 Firewall Entry which I assume I would not select)
Description:
Public UP Ports:
Public TCP Ports:
Private IP Address:
Private UP Ports:
Private TCP Ports:

Any help is greatly appreciated.

Put the same port number for both public and private poets (X4) and the Roon core ip adress for private ip address. That is all i did on my extreme and then it auto finished .

1 Like

Thank you! Will try in the morning and update.

Works like a charm! Many thanks!!

2 Likes

Hi guys, I’m having the same issue and tried to follow along with the suggested steps and it’s still not finding it - would you mind taking a look at my screenshots to say where I’m going wrong?

Thanks in advance!
Sam


Screenshot 2022-09-21 at 13.44.31

Your using the wrong ip on the port forward it needs to be your Roon core IP. Which is shown in the arc bit of main app in your image as 10.0.1.2. I would set a dhcp reservation in the router for the core sothat it doesn’t change the ip at anytime.

1 Like

You are not using any mesh system after the router are you?

make sure you have saved data and updated the AirPort Extreme.

I don’t know what a mesh system is, and googling it, no I don’t have one of those… One thing I haven’t mentioned is that my Apple Airport Time Capsule is plugged in to my Virgin Media Hub which is where the internet comes in (the Apple has a better wifi reach than the Virgin) … Could that be causing the issue? I should use the Virgin wifi network instead, and set it up on the virgin router as I did before on the apple?

Thanks guys!

I had done that, but thanks for the suggestion!

Is the virgin hub in modem mode? If not then yes you have a double NAT which will cause it not to work. I have virgin and my own router but the hub is in modem mode. I suggest you do the same.

It worked! Thanks so much for taking the time to help me! :slight_smile:

2 Likes

Glad you got it sorted

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.