ARC setup using AT&T passthrough setting on router [resolved, also verizon screenshot]

I have an AT&T gateway that is in charge of my Internet and my local network. I know precious little about networking.

When loading up Roon Arc I had Roon test my network to see if it worked, and it failed. This gateway does not support UPNP. So I found “IT Passthrough” in the gateway and enabled it as seen in the screenshot. This allowed ARC to pass the self-test, and ARC works.

Does doing this compromise my network’s security in any significant way? Near as I can tell, this specific MAC address and this specific port are exposed to the internet, but nothing else is.

It’s not a great idea. You are allowing the internet to access anything on that machine. You really should limit it to roon and whatever else you need

2 Likes

Thanks. I’ll search for a better way to do that. This was the only thing I could find that allowed ARC at all

The thing you probably need is in the nat/gaming tab

2 Likes

Thanks much. I’m looking at it now and see I can create a “custom service”. I’ll give that a go and report back.

Alrighty, that seemed to work. Thanks for your assist.

Will ARC change the ports it attempts to use automatically if I restart the core? I had a hard time getting the gateway to save the changes unless I severely narrowed the range of ports it could draw from for this custom service.

For anyone else who many have this gateway (AT&T Fiber) it’s the BGW 320, and I got into the “NAT/Gaming” section of the Firewall and enabled a custom service for Roon for just the core on my network.

you can always go to settings → roon arc → down arrow → change the port input box

it’ll start using that port

1 Like

I appreciate it! I set it and matched the port number in the NAT/Gaming section of this service. I rebooted the core and it continues to work.

2 Likes

Port Forwarding is your solution…

1 Like

@Dan_Herrmann that looks like a Verizon router UI, and @Doug_Hannah has an AT&T system… but he got it working already.

That said, if anyone needs Verizon gateway help, look at @Dan_Herrmann’s screenshot above!

2 Likes

Thanks. Yes that’s what it came down to, but AT&T puts it under “NAT/Gaming”.

I have the same router and see where I can choose Roon on the second field however what do I put in the first field where it just list the name of games?

Actually , I think I have six fields to fill in with the router if I create a custom one. Can you guide me with what to input?

It won’t let me screen shot since the service is running and I can’t pull up the edit screen for you. I added a “custom service” and then chose the computer in my network from the drop down. It filled in the IP address.

I had to change the “port range” to a very narrow field and I choose the currently in-use port as the “host port”. Once I added everything it said “changes saved” and ARC began to work. Otherwise, the gateway complained the “port range” I was using had other services occupying one or more of those ports and I needed to try again.

Then I filled in the port info, which I got from the Roon Help instructions, listed here

Sorry that’s not more helpful but that’s what I did

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.