Arc Sync Issue Samsung S10 Plus

Hi, this is my first post and I´m not sure if it´s ok for me just to jump in here or not but here goes.
I have a Samsung S10 plus (android 12) and had Roon ARC installed and working perfectly well until I wanted to hook up to a different core. I simply couldn´t figure out how to log out of the account I was logged in to so I uninstalled the Roon ARC app from my phone with the intention of simply re-installing again.
However, I am now experiencing the same problem as danny 2. I´ve tried uninstalling, clearing Google Play cache and re-booting may times but get the same result each time - The ARC logo - that´s it. I´m already missing the app - life is hard without it :frowning:

Hey @Pete_Lee,

Welcome to the community! I’ve broken off your reply and opened a fresh thread with it to ensure you receive proper attention.

With that, can you also provide necessary system information below:

Roon Core Machine

Include your operating system and machine info (Model, CPU, RAM)

Networking Gear & Setup Details

Your network gear (model of routers/switches) and if on WiFi/Ethernet

Connected Audio Devices

Specify what devices you’re using and their connection types, like USB/HDMI/Chromecast, etc.)

Number of Tracks in Library

Tell us how large your music library is, eg. “30,000 tracks”

Description of Issue

Tell us about the problem you’re having in as much detail as possible. Screenshots are always appreciated!

Can you provide more information here? Arc aside, had you already unauthorized your old Roon Core prior to Authorizing and setting up your new Core? Are you able to connect to your core using the device as a normal Roon Remote?

I’ll be on standby for your reply :+1:

Hey Benjamin, all the info about my system really isn´t relevant. The problem is that I had ARC running on my phone (and working fine), I uninstalled it and I´m unable to re-install the app again. I can install the app on another Samsung phone no problem and it works as it should. I actually work for Tekni-fi - the distributors for Roon in Denmark. I was hooked up to our server at work with ARC but just got my own Roon server at home and made my own account which is why I wanted to log out of Tekni-fi´s account (on ARC) and log into my own. I could not find any way to log out out so I deleted the app. Afterwards, I looked at the app on a colleagues phone and saw he had the option to RESET which I didn´t and made me start to think that perhaps the app had never fully installed on my phone in the first place? I installed ARC on my girlfriends Samsung S8 last night without any issues. As I wrote before, I have comepletely removed ARC from my phone, cleared the Google Play cache, re-booted my phone but still cannot install ARC. It downloads then I click on install then I get the ARC logo(large) on my screen then nothing.
My Samsung S10+ : Android12. ONE UI version 4.1 Baseband G975FXXUGHVJ1. Kernel 4.14.113-25257816. Knox 3.8. Knox API level 35. Knox ML 1.2 DualAR1.4.0
Best regards, Pete
PS. Anyone can download and install the ARC app - even if they don´t have Roon. That´s what I meant about my system details being irrelevant.

Hi @Pete_Lee
I’m sorry you’re having such troubles with your phone and ARC.

The whole thing reminds me badly of months of uninstalling, reinstalling, deleting caches, sending adb logs over and over, never-ending hassle with my Note 10+ and Roon remote (ARC didn’t exist then).
Of course I cannot know if your issue is related to my case regarding possible problems with Samsung’s One UI and Roon.
But I would like to point you to my thread and the solution I finally found by pure chance. It could possibly save you months of trouble.

Thanks for your input @Axel_Lesch but OMG! Reset my lifeline?! I know nowadays it´s much easier to backup, reset and reinstall but something always goes wrong. It´s difficult to explain but there are some extremely secure apps which you need to do almost anything here i Dk and since I´m not a Danish citizen, it would mean I would have to get a new appointment with Immigration just get approved again! I must admit, I have a feeling re-setting my phone wold do the trick but all too much hassel. At my summer house, I have another Samsung phone which I have ARC installed on so I´m covered there - I just won´t be able to use it in my car. For now, I think I´d rather wait and see if another solution comes along.
Cheers, Pete.

1 Like

Hey @Pete_Lee,

We’re seeing hundreds of network-based errors around your core diagnostics, which could certainly be part of the issue here. If you could at least provide more information around your router and network and any VPNs or additional network gear being used, that would be helpful.

With this, are you able to download Arc from the link below:

1 Like

Hi @benjamin.
I installed from the link you sent and it works! All good now! About the errors you’re seeing - maybe just because of all the messing around I’ve been doing? Should I still sebd your my network info?
I’m away at my summer house now før the weekend but can connect remotely to home and dig out the details. Could be interesting to hear what you say about it. Anyway, I’m really happy it works now - thanks for your help and support.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.