ARC - Time for an update - Update Roon Server to reconnect

Hi All,

With the latest release in Early Access, there is a compatibility line in the sand we’ve had to draw to power some features in ARC. What this means is that ”older” Roon Servers cannot connect with “newer” versions of ARC.

If you are running Early Access ARC and Roon Server, you can simply update your Server remotely from ARC.

However, for those of you who may be running Roon Server production with EA ARC, this will not be possible. If you are seeing a “Time for an Update” screen, what it likely means is that you are running the latest EA build of ARC and an older, incompatible Roon Server. If this is not the case, please post your issue in Support.

How can I check what I’m running?

  • On iOS: If you’re in EA, your version number can be found in TestFlight. If not running Testflight, you’re on production.
  • On Android: Long-press on the app icon, select App Info, and scroll to the bottom.
  • On your Roon Server, check the “about” page.

Here’s a quick reference for the latest build numbers:

  • Roon Server: EA is 1355, production is 1353
  • Roon ARC: EA is 222, production is 220

How can I resolve this?

    1. Update your Server to the latest Early Access version. Instructions can be found here.
    1. Align both your Server and ARC to the stable/production version.
    • For iOS, delete the TestFlight app and download the standard ARC app from the App Store.
    • For Android, exit the Beta program and reinstall the production app. Details can be found here.

We generally recommend using ARCs and Roon Servers from the same track (EA with EA, production with production) to ensure compatibility. However, we understand that keeping track of updates and versions can be challenging, and sometimes mix-ups happen. :person_shrugging: We try to design Roon ARC with maximum compatibility in mind, but certain architectural constraints sometimes make this difficult.

Moving forward, we will try to communicate more effectively about potential incompatibilities. Thank you for your understanding and patience!

1 Like

Thanks, Michael. That guidance helped resolve my issue. Turns out that I have Roon Server production (1353), but ARC was Beta. However, even after leaving the Beta program and uninstalling and reinstalling the app, it still showed the same error. It seems the reinstalled version had the same app version (1.0.45), and I had to force stop it in Settings, then uninstall it, and only then did it install the correct app version, 1.0.44. Issue resolved. Thanks!


you can keep saying that we have the wrong version of arc, but that does not help us. put the correct version of arc in the Google Store so we can fix it.

where can we download the early access version of the roon server, it sounds like that would fix it also.

I am not a member of the beta program. I can not leave it.

@Suedkiez is not a staff member of Roon Labs - he is a fellow user, just like you - as his signature states.

Can you clarify what versions of both the Roon Server and Roon ARC you have, and whether you want to be in the Production or the Early Access stream? Thank you.

Thanks, that really helped. Force quitting the app was the key to reinstall the correct non beta version.

1 Like

This is what I sent you, but I was not aware that you were a volunteer (sorry). I now have roon server build 1355 and room arc build 100222. I don’t care what the builds are, per se, but I don’t want my stuff to stop working without reason. I would like messages that will help troubleshoot the issue “time for an update” made me try to get and update which was not available. I don’t know why you pushed the early release version of Arc to my system (even if I signed up for it, which I did not) without pushing the early access version of the Roon server.

Thank you for following up.

Tebby Wafer

I get all of the explanations; what I don’t get is why you did not do a version check of the server and a rollback and notice if necessary. Good software dev ops…

1 Like


I’ve just started getting this issue.

My Roon Core is a NUC11i7TNH running ROCK version 2.0 (1352)

My phone is a Google Pixel 6 running Android 14 with all of the available updates applied and running Roon ARC 1.0 (222) (1.0.45) and is connected via WiFi to my private network (and thence the Roon Core).

This device has been working flawlessly with Roon ARC to date but this morning when I started it (out of interest after reading this forum), it started displaying the ‘Time for an update’ screen:

ARC still works in offline mode.

The following images show the status of my Roon system:

Roon ARC:

ROCK web page (displayed on the mobile in question):

Roon About page (displayed on the mobile in question):

I tried rebooting the core - which achieved nothing.

I then tried resetting Roon Arc - which did not seem to work.

I then tried deleting the Roon ARC app data on the Android Phone and finally, completely uninstalling and re-installing Roon ARC. Both of these actions resulted in the same consequence: On sighning in, I got a display again reporting that it was ‘time to update’ the core:

I do not believe that anything has changed on my network (no router settings changes (and no other managed devices), no Roon Core/ARC updates.

What has changed is some google services on the mobile were updated within the last few days. They are:

  • Private Compute Services
  • Android System Intelligence
  • Google Drive
  • Adaptive Connectivity Services

For further information, I have never installed the early access versions of any of the Roon components and I am not signed up to beta services on the mobile.

The standard Roon Remote app on the mobile in question continues to work perfectly.
My wifes mobile (a Pixel 7) continues to run ARC with no issues. I’m not sure of the update state of that phone.

Try forcing a Stop on Roon ARC, then go into the Play Store, pull up the details for Roon ARC, scroll down and leave the Beta. Then uninstall and reinstall ARC, and you should get the production version.

BTW - I’ve removed your screenshot showing your email address to keep your privacy…

1 Like

OK. That fixed it - kind of. I had already left the beta program and uninstalled the beta version some 2 months ago - but for some reason it was still installing the 1.0.45 version (Even though it offered a ‘Join the Beta’ in the Play Store Roon ARC app data.

I repeated the process that you advocated 3 times with no success - each time 1.0.45 was re-installed. However, on the 3rd attempt I noticed:

On seeing this, I uninstalled again, Force stopped the Play Store App, cleared the Play store app data cache (but not the app data itself), rebooted the mobile and then installed Roon ARC again. This time 1.0.44 was installed and it is back to working properly.

I wonder if others are suffering the same issue? Despite withdrawing from the beta program, the beta version continued to be installed.

I only joined the Beta program briefly about 2 months ago to test out a version with updated USB driver support and then left because it did not help.

I think it can take a bit of time until Play Store updates its configuration after leaving beta; this seems to be variable and is up to the Play Store. If it doesn’t switch immediately, leave beta, uninstall ARC, and then wait some time until you reinstall

But ~2 months? Admittedly, the original install of 1.0.45 that I reported today would have been done just after leaving the beta program. However, when I uninstalled and re-installed today, it still installed the wrong version - until I cleared the play store cache and rebooted the phone - then it immediately installed the correct version.

Hopefully, you read in this issue that your version of ARC is incompatible with your version of Sever. I finally changed my version of Server to the early release version (in the thread). backup Roon, uninstall your current Server version, download the early release version (see link in thread), and install. This worked for me. I could not install the production version of ARC. I could only get the Early release version. Roon says I signed up for it, but when I tried to revoke my early release signup it said that I was not signed up for it. I think they accidentally promoted the early release version of ARC to production.

If so, then everyone would have received it, not just a few

@Joe_Rogoiyo thanks so much for that post. solved it for me!

Just found this and it solved the problem for me. Thanks! :saluting_face: