ARC - Time for an update - Update Roon Server to reconnect

I just wanted to test my new wireless IEMs, and got an error message:

“Time for an update - Update Roon Server to reconnect”

I’m on RoonARC1.0 (222), Server 2.0 Build 1353

Any idea how to fix this?

1 Like

Just got the same myself. Any help Roon?

Guys, the ARC version in the Production channel is:

While the Roon Server version is the Server 2.0 Build 1353 from this later update.

If you have ARC build 222, are you using the Early Access version of ARC that was just released?

If yes, then stop using mixes of Production and Early Access. It will create problems

1 Like

Well… ARC had the option for beta on Android, so I tried. It did not mention requirements for the server.

Anyway, I left the beta program re-installed ARC, but it still wants me to update the server?

Reboot your Roon server, clear Arc’s cache and data

Did that. No dice.

Did you completely uninstall ARC and then reinstall while making sure it’s not using the beta again?

I think if you only switch out of the beta channel, you probably stay on the beta version until the next higher update comes through the regular production channel.

Worked for me

Same here, cant use Arc.

I’m getting the same error but I want to be on early access (to see if my USB DAC support gets fixed) how do I get Early access for ROCK server?

I’m having the same issue. Arc got updated and now this message appears: Time for an update

I had this yesterday after Arc updated from play store.

In roon remote app 》settings 》 about : there was an update available for server.

So went through update option and arc (1.0.45) then connects to updated server 1355

Im running early access on server / remote and arc.

Latest server update to 1355 also fixed android connection problems that i had when server was on 1354.

Android remote app is still 1354, no update available yet.

I googled and use this:

As the release notes say, there is none this time. If you run Early Access, I’d really recommend to read the release notes

1 Like

I have now re-installed the Synology server to early access (1355) which makes the error go away.
Pretty certain that’s not how it should be.

I wasnt asking for / expecting an updated app.

I only mentioned it as the same app can now access updated server. That was not possible for the last server build.

It appears my Core is in production (the way I want it) but Arc is in beta.

The below is a screenshot of the play store. I am able to opt out of beta.

Leaving ARC beta was not enough for me.

I had to “upgrade” the server to earlyaccess in order to get it working again, ARC production + Server production did not work. either.

1 Like

Yet another fine roon labs screw-up. My core/server/whatever is 1353, i.e. not updated, though it says it is the latest version. Lovely staged upgrade screws everything up, of course, roon’s usual mode of operation. Arc on my Samsung tablet is still at 221. The Arc on my Pixel 6 phone keep asking for the core to be upgraded, however that would be possible. Tried to reinstall Arc on phone, but to no avail. Only a Beta version is available in Play Store, download the early access version demands the copre/sever/whatever update. So no A4rc for me, and soon no roon for me if this nonsense keeps up.

It is the current version in production, so this is correct if you didn’t switch Roon on the PC to Early Access

The regular app version seems to be in the Play Store just fine:

Note that there is a button in your Play Store on the phone/tablet for each app where you can decide to switch to the Beta version. Did you inadvertently do that on the affected phone? There should then also be a button to leave the Beta

Which is also an Early Release / Play Store Beta version that was never released regularly as a Production release.

If you really got these Beta updates from the Play Store without you choosing Beta, then something is wrong either with the Play Store or Roon‘s submissions to the Play Store, but do check if you really didn’t do that :slight_smile: