ARC works on one port but not the other

Hi all, following the issued I had depicted here -

As stated in the original post, I had resolved the issue I had, and the issue was that I had unknowingly switched ISP’s, and the new ISP put me behind a NAT. Once I sorted it out with the ISP, ARC started working again.
Well, that didn’t last very long and a couple of days later ARC stopped working.
I tinkered around with it and what I found out was that when I changed the port from 55002 to 55001 on both the Roon core, and on the port forwarding of my router, things started working again. When I go back to 55002, it doesn’t work.

Could it be that the ISP automatically blocks ports which it suspects have unusual activity? Has anyone had something similar happen?

Thanks

Did you recently go to Roon - Settings - Roon ARC and click the down arrow to verify what port ARC is now using? As long as you use the same port number for port forwarding, does it work?

Yes, the port on Roon is the same port as in my port forwarding rules.
When both are 55002 it doesn’t work (and it used to), and when both are 55001 it does work.

1 Like

Yeah. I have Deutsche Telekom as my mobile provider and ARC did not work for one night and day recently, then continued as normal. This was during a recent large-scale cell network outage in Germany, which however didn’t much affect DT.

A port scan from my phone to the Core suddenly revealed the port as closed, but only when the phone was in the DT network. The port was open and ARC worked from other LANs and from the Vodafone cell network.

I’m thinking DT might have closed ports either trying to protect them from whatever caused the outage, or they just closed down as much as possible when maybe they didn’t know what was going on, or it was a result of a technical issue that caused the outage. Or some unrelated glitch, but anyways such changes can happen.

1 Like

Well it’s different for me because even at the core the ARC test page reported that it wasn’t working, and I couldn’t use ARC from inside my LAN or from the cellular network.
I guess if it is some automatic port blocking by the ISP then it will happen again in a few days for the new port, but I just wondered if it’s something ISP’s do. Seems strange to me, and it would be strange if that port is only blocked for my IP.

Point was that the ISPs and cell providers selectively may close ports for whatever reason. If they did it in my case, they very well may do it if they see activity they deem suspicious.

2 Likes

Shields Up is the long-lived, tried and true strategy for examining your open ports. It’s not easy to share links to specific pages in the site. If you go to https://grc.com, and navigate your way into Shields Up (which will take a bit of effort), you can have it scan common ports or specific a custom port.

The site isn’t pretty and the clickable elements don’t always look clickable. I don’t think the site has changed much since the 90’s. Dig around and look for the “User Specified Custom Port Probe” option. Type the number of the port you want to test. Here’s an example of what it should look like with one of the ports you mentioned filled in.

Then click the words “User Specified Custom Port Probe” and it’ll tell you if the port is open or not.

At least that’s a way to test your theory.

1 Like

I used this

Is it different?

No idea. I’ve used Shields Up for a very long time. Your earlier posts didn’t mention your use of a port probe. Based on your last post you already do, so feel free to ignore my recommendation.

@Chikolad
Here’s what I would do:
Disable port forwarding in the Asus router and restart it.
Uninstall ARC and reboot the phone.

Go to WAN router settings, enable UPnP and reboot Router with entire network and Roon Core.

Make a fresh install of ARC and try.

Are you saying UPnP should work with the Asus?

For me it does. With a public dynamic IPv4 adress without hassle out-of-the-box.
When the port number changes every now and then, this has no effect.

Thanks, I’ll give it a try

Don’t give up if it doesn’t work right away. If necessary, reboot the Asus and then your core once more.

Hey @Chikolad,

I wanted to follow up on this thread to see if you were still having issues with port setting in Arc?

I’ll be on standby for your reply :+1:

Hi @benjamin, so far port 55001 continues to work. I have no idea why it had stopped working with 55002. Maybe just a glitch in my router.