ARTIFACTS - windows 8.1 - latest roon version

When I installed the latest 1.8 roon version - artifacts started showing up on the screen. I am using WINDOWS 8.1 - 64bit. The earlier version of ROON worked perfectly. I tried to reinstall ROON but there is no improvement. Artifacts appears when I’m moving the cursor and scrolling through songs in a playlist. Does anyone have the same problem?
Please let me know how to fix this?


I don’t have that issue but I’ve seen some people posting odd screen shots, do some searchs, but also check out your screen size and perhaps your drivers. The screen size is an easy one to check.

The screen size is set 1920/1080.
all other applications are working properly - only with r1.8 oon I have a problem.

I found a solution.If you have any arrtifacts - you need to unistall roon and restart your windows 8.1 system - next go to Roon Software Downloads - PC, Mac, Linux, Android & iOS | Get it Now and select the correct operating system - I chose Windows 64bit. Next step is to install roon 1.8, - after then link the account with tidal, spotify etc. and all it’s done. NEVER INSTAL ROON if you have previous version on your PC. Before installing new ver. you need to unistall previous roon version.

1 Like

You might try in no particular order:

  1. Installing the lastest video drivers
  2. Using the 32 bit version of Roon
  3. or follow this Green line display artifacts in 1.8 [Intel Bug, Update Your Drivers] - #32 by allan

Unfortunately, the symptoms came back after turning the laptop on again. I’ve tried everything and still have artifacts when moving the mouse. All other applications run stably and properly. Only in Roon 1.8 I have a problem. In version 1.7, I had no problems. Is it possible to download version 1.7 until you fix the bug in version 1.8?

Please see how it works on my lenovo y50-70 win 8.1 64-bit (intel HD 4600 and NVIDIA GeForce GTX 860M)
i7 ; 16gb RAM. I also have latest version of iNTEL HD 4600 graphic



quite possibly i found a solution … because v1.8 again displays correctly.
So in the screen settings - the default image display was set to 125% and it was causing artifacts. After changing to 100%, it works fine, Although I would prefer the size of text, icons, etc. on the screen to be set to a larger size. =. 125%
Well, it’s better than dealing with artifacts.


FINALLY someone with my same issue!
Apparently, it has to do with setting the display scale to more than 100%
I hope this issue gets addressed and then fixed.
Setting it back to 100% is not a solution of course, since many of us are using high density monitors, and we wouldn’t see crap with 100% scale.
Some system info:
Windows 10 x64
Nvidia RTX 3090
Latest video drivers
Display scale set to 150%

Unfortunately, settings greater than 100% cause problems with quite a few apps. Roon isn’t the first, and it’s unlikely to be the last.

Well, this never happened with previous versions.
And I mentioned that I’m hoping that this bug gets a fix… if it doesn’t, I’ll see how much it bothers me when it’s time to renew the license I guess.
All the apps with problems when the display is set to something different than 100%, are caused by developers not considering that there could be different DPIs.