Artwork disappeared

Hi everyone, I am seeing the same issue on my machine, with the same exact repro steps as Roqxide.

I am running Roon Server and the Roon client on the same machine. (I use the PC for other things too, so I don’t want to “merge” the two and make this machine an exclusive server).

  • If I kill Roon Server when the client is open, after relaunching the Server, images re-appear.

  • Clearing the image cache doesn’t help.

  • I didn’t notice this behavior until I updated the default cache size to 512mb, up from the normal 256mb. I have since switched it back to 256mb.

  • Recently I’ve been loading up a ton of ripped CDs, updating artwork, etc.

  • Machine info: Intel Nuc8i7, Windows 10 Pro x64 build 2009, 16gb RAM, 512gb Samsung 970 Pro. I transferred my Roon server instance from an older machine last week, so this is a “new” build, using a restored backup from the other machine.

Hoping this can be looked into, I think there might be some issue here!

Hi @Chris_Haklitch,

Can you please share a screenshot of what you’re seeing in Roon?

Do you by any chance have Logitech G Hub software on the affected PC? Are you using any VPNs or firewall tools which could be interfering with Roon?

Below are the screenshots. Literally no images, even for artists, Discovery images, etc.
No VPN, but YES- I do indeed have G Hub installed on this machine (and not on my previous machine). Any known issues with this program?

Might be on to something!

Hi @Chris_Haklitch,

Yes, we are looking into similar issues due to Logitech G Hub, we believe the issue is because this program and Roon try to use the same port number.

We are investigating what can be done to hopefully prevent this issue, but in the meantime, can you please try to uninstall G Hub and verify if it resolves the issue?

Yep this worked. Disabled the updater startup service in Windows, restarted Roon client and images always load.

Interesting issue! For now I’ll just leave G Hub disabled (and my keyboard LED theme unconfigured haha)

1 Like

Hi @Chris_Haklitch,

Thanks for letting us know that disabling Logitech G Hub resolved this issue for you, that’s fantastic news!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.