Artwork not shown (local + from Qobuz and Tidal) - random behaviour

Core Machine

ROCK (Version 1.0 (build 227) stable with Roon Core Version 1.7 (build 667) stable) running on PrimeMini 4 with Intel Core 8i7-8650U vPro (NUC7i7DN), 2x8 GB DDR4-2400MHz, 2 TB SSD internal storage

Network Details

I’m located in Munich/Germany, connected via 100/44 Mbit/s DSL. My DSL router (Fritzbox 7490 with latest Firmware 07.21) acts as WiFi Mesh Master (2,4 and 5 GHz / Fritz! Repeater 3000) to connect the Roon Remotes ( (all connected by WiFi: iPhone 11 Pro, iPad Air, MacBook Pro, all latest firmware and latest Roon software).
The Core is wired via Gigabit-Ethernet to the router, as is the main system network streamer (LUMIN).
Whole Network uses DHCP, as is fast and stable.

Audio Devices

➜ Ethernet
➜ Fritzbox 7490 (DSL Router, WiFi Mesh Master) with LPS Sbooster BOTW P&P ECO 12V MKII
➜ Ethernet
➜ (A) Uptone EtherRegen with Farad Super3 9V LPS (B)
➜ Ethernet
➜ LUMIN U1Mini (Roon Endpoint, Spotify Connect)
➜ Matrix X-SPDIF 2 with with Farad Super3 6V LPS
➜ I2S (HDMI)
➜ PS Audio DirectStream DAC
➜ XLR to Preamp

Description Of Issue

When browsing my library (4900 albums total, 1300 local files, rest Tidal and Qobuz) on my three remotes the artwork of albums repeatedly is not shown. The music plays fine (sometimes takes a bit to long to start, like 5 to 10 seconds).

It displays the title, on which service available etc., just the images are sometimes not loading (see screenshots, where only titles not in the library are affected, but sometimes these are also not visible. It feels random). This is very much annoying. It would be great if you could find a fix to that. I searched the forum but did not find a similar issue, so I guess it’s OK to post this here.

What I already tried:
DNS: DNS is set on remotes and Router to Cloudflare ( and Google (
I also restarted the router, restarted the core, restarted the remotes and cleared image cache on all remotes. Repeatedly. I’m running out of options here. Maybe you can see something in the logs? That would be very helpful. Thanks a ton!

After re-starting the router it seemed ok for 2 days, but today I experienced it again on my MAC (see screenshot - albums sorted by latest addition. The Sinatra album was just added.):

When going to the album, the cover art work was loaded, but you see missing images on the down right (from Tidal and Qobuz) again:

Any hint from @support where to look to start fixing this would be greatly appreciated.

Hi @Philipp_Schaefer,

If you go to Settings > Setup there is an option to Clear Cache as well as adjust the memory available for images. Can you try increasing the memory option?

Does it happen to all remotes at the same time? Can you give some additional information about these remotes?

Hi @dylan,
thanks for looking into this.

My remotes are:

  • iPhone 11 Pro, 256 GB, latest iOS (14.2) and always up-to-date with Roon version
  • iPad Pro (9,7’’), 256 GB, latest iPadOS (14.2) and always up-to-date with Roon version
  • MacBook Pro (13-inch, 2017, Four Thunderbolt 3 Ports, 3,5 GHz Dual-Core Intel Core i7, 16 GB 2133 MHz LPDDR3, 500 GB SSD), macOS Catalania 10.15.7, latest Roon Version

The cache on all three remotes is maxed out (2048 MB).

I cleared the cache repeatedly on all remotes. Sometimes that helped for a while. But the issue always comes back.

Yes, when it happens, it happens on all remotes. Again, if feels random. Today it’s all OK on all remotes. But it will come back… Can we look into some logs to see the status of the artwork fetching when it happens?

@dylan I was able to narrow it down: seems like an issue only on the MAC client.

When on my MAC suddenly the artwork was gone, but my iPhone still showed them (both using wifi). After restarting the Roon software on the Mac, some artwork showed, but most didn’t (also local files).

After restarting the Roon Server Software all was good. So it seems to be an issue between the Core and the Mac client. Maybe that helps to narrow down that annoying behaviour.

Hello @Philipp_Schaefer, so we can get accurate logs could you please do the following?

  1. Open an album that isn’t showing art
  2. Reply here with a timestamp (in your local timezone) and the name of the album when you do this
  3. Use the directions found here and send us over a set of logs using a shared Dropbox link.

@nuwriy Thanks a lot. Will send the timestamp and logs when the issue appears again.

@nuwriy - here you go:

Timestamp: December 15, 2020, 15:24 / 15:25, Munich / Germany
Album: The Pogues, If I Should Fall from Grace with God (Expanded Edition), via Tidal

Artwork on macOS won’t display, also on “Recommended For You”, and rest of library.
Artwork on iOS is displayed without any issue.

Logs can be found here:

Thanks so much!

Hello @Philipp_Schaefer, and thanks for the information! I’ve sent this over to our QA team for further input and will return once I have their feedback!

1 Like

Thank you :pray::+1::musical_note:

Hello @Philipp_Schaefer, so I spoke to the QA team about this thread, and for the next step could you please try the mac as the core and see if the artwork shows up? This would be a temporary but incredibly valuable test. I’d also like to collect timestamps and diagnostics from the mac

Sure, @nuwriy, thank you for further looking into it!

I’ll try to set that up. But the Mac / Roon Core will then be connected via WiFi, as I have no option to run an Ethernet cable to the router/switch. Hope that will still be valuable.

Hi @nuwriy. I was able to replicate the issue with the core running on my Mac (macOS Catalina 10.15.7, MacBook Pro (13-inch, 2017, Four Thunderbolt 3 Ports, 3,5 GHz i7, 16 GB RAM)) while playing on/from the same device.

The timestamp was 20th of December, 21:34 - 21:36
The Album was Noa, Noapolis - Noa Sings Napoli

I randomly added the album to the library, and no artwork was shown. When I then went to the artist page, also other artworks were missing (see screenshot below).

After ending and starting Roon again (restarting the Core), the issue was gone, all artwork showed up just fine.

Please download the new logs here:

One thing to add - not sure if in any way related - after setting up the core I only added two local albums to the library and then connected first Tidal, then Qobuz. Both connected fine, but Qobuz most of the time didn’t start playing any music, the play-bar was indicating the loading, but nothing happened. When I then switched to the Tidal version of an album with that behaviour, these started to play immediately from Tiday. Probably / hopefully just a temporary issue with Qobuz.

I hope that helps to shed some light onto this strange behaviour.

And - just to confirm - issue shows up again on reactivated “old” core:

Hello @Philipp_Schaefer, and thanks for the update! I ran this information by the QA team and after taking a look, they wanted to know if you could reproduce the issue with the mac as the core on a different network. This could be a Wi-Fi hotspot you make with your phone, please let me know if the issue continues in that configuration or if you have any questions! The reason I ask for this test is that we’re seeing Roon timing out when looking for images.

I‘ll set this up and see, if I can replicate the issue with tethering the Mac/core through my mobile phone/network.

It will take some days until I will find the time to do this, as we are renovating the flat atm.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.