Artwork transparency not showing

I’ve just come across this issue, and it’s never been a problem before.

When I add an image with transparency (.png) as the album cover, Roon isn’t showing the transparency. It shows fine in Windows file explorer and Windows photos - see screenshots below. Of note, other images with transparency do work in Roon. Is there a particular setting or something that needs to be enabled when saving the image for Roon to show the transparency?

How it should look:

How it shows in Roon:

Further information which I hope will be useful here:

I go to edit the album, and go to album art:

I manually add another (renamed) copy of the correct image. Looking at the album art after doing this, it shows both images:

If I select the second one, it looks correct:

If I select the first one, it looks incorrect i.e. without the transparency:

I select the second one and select the option “Set as album cover”:

But as soon as I do that, the second image disappears and it just shows the first (incorrect) one as the album cover:

Why is Roon doing this to my art, and how can I fix it?

1 Like

And thoughts on this one anyone?

Hey @extracampine,

If possible, can you please share a screenshot of your image import preferences? With that, I would also suggest clearing your image cache in your settings as well :+1:

I’ll be on standby for your reply


Hey @extracampine,

Apologies for the delay. What happens if you select ‘Prefer file’ under Artwork?

Same problem @benjamin

It’s showing the correct image from my folder - it’s just not rendering the image correctly.

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.