"ASIO output warning: sample rate mismatch" Windows + HQPlayer + Chord Hugo TT 2


I’ve switched from using HQPlayer on a mac to windows so I could upsample my roon library to DSD 512.

I’ve downloaded the Chord TT 2 ASIO driver and installed it.

I’m using the same HQPlayer settings I’ve always used, but on windows it just does not work.

Here’s the chain:
Roon on mac mini -> HQPlayer on Windows -> Chord Hugo TT 2

I can only listen to music without upsampling. If I try to upsample to any DSD rate all I get on my headphones is a crazy loud static noise, hiss and a few pops.

The status bar on HQPlayer shows the following message: “ASIO output warning: sample rate mismatch 768000 vs 12288000”.

This may be a very silly beginner’s mistake, but I can’t for the life of me figure it out. I’ve never used windows for audio.

Did not solve my issue: rebooting the PC, reinstalling the Chord ASIO driver, messing around the control panel (disabling and enabling TT 2 as an audio device, ticking the supported format boxes, etc).

If someone needs more info please let me know, this is driving me crazy.


Hi @Lawshredpower,

The Hugo TT is connected directly to your Windows machine, correct? What is the behavior of the DAC if you try to play DSD content outside of HQPlayer, does it work as expected? To clarify - if you install Roon on the Windows PC and connect to the Mac Mini Core on the “Choose your Core” screen, does the TT behave as expected through Roon directly without HQPlayer involved?


I assume that you went through this effort to send “native” DSD to the Chord. If so, then for me SDM Pack, is set to None, not DoP, when I send native DSD to my DAC.

Hi, @noris

Thanks for the reply. I performed that experiment as you asked. It doesn’t even play the track. It tries to play, then the Hugo TT 2 disappears for a few seconds from the audio zones list. Here’s the settings and a screenshot right before the TT 2 crashes. So… what could it be? What am I doing wrong? I’ve got a few updates on the HQPlayer situation. I’ll write it down now.

Hi, @Rugby. Yesterday I talked with some friends and did a few experiments. You are indeed correct.

Frist, I’ve changed the bit rate from 48k to 44.1k, that solved the issue almost entirely. Which is weird, I was doing 48k x256 on mac with no issues at all. Why is that? I really know nothing about clocking, etc.

I turned off DoP and enabled adaptive output rate when needed. This was the setting with the least amount of static and pop I could manage, but there was still some.

With that, I started messing around filters and modulators. Each combination yielded different results. I’ve finally ended up finding a combo that has zero noise. Impeccable. See screenshot below. But is this normal? I mean, when I used HQPlayer on my Mac it either reproduced the tracks impeccably or it did not play at all. The first couple of seconds of the first song still get some static while the processing is catching up. What’s up with that?

Thanks for your help!

Glad to be of help.

The difference could be the difference between using Chord’s ASIO driver which is different than a MAC. A Mac can only output DoP which is DSD that is wrapped in a PCM Wrapper, that is probably why the SDM Pack was set at DoP.

DSD has native sample rates and not all DACs handle both rates.

As for questions, you might want to ask the creator of HQPlayer who is around this forum, usually under the HQPlayer section. He can answer better the fundamentals of his software and which settings are the best.

1 Like

Hi, heres an update:

I’ve uninstalled and reinstalled Chord’s ASIO driver. It seems that fixed the problem for that moment.

To try something different, I’ve configured HQPlayer to PCM upsampling to 768k and guess what? Same problem I’ve had upsampling to DSD. A lot of noise, static and an almost tremolo-like effect to the music. Now I’m lost and frustrated. I regret buying this NUC. I was happier running less demanding settings on my mac lol

Hello @Lawshredpower,

Seeing that the reinstall of the drivers resolved the playback issues with Roon I’m going to marked this thread as solved. If you have HQPlayer specific questions I would reach out the HQPlayer support team or create a new post in the HQPlayer topic.


Uh… but it didn’t. I still get sample rate mismatches even on PCM.

Here’s the real solution:

Installed hqplayer embedded.

No more windows, no more ASIO bs. Works like a charm. Native DSD was not worth the headache :slight_smile:

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.