ASUS ROG - RealTek HD Audio

But I do need the Realtek HD Audio on my ASUS ROG Maximus X Hero (Wi-Fi AC). Any additional assistance with this would be appreciated. As mentioned by others, everything else on my PC works fine with the Realtek HD Audio, can’t understand why the Roon would be exception?

Hi @QB_White ---- Thank you for the report, the insight is appreciated!

Moving forward, I have split your post out to it’s own thread so we can address this concern with you more directly. Currently, are you experiencing troubles with your “audio” zones as mentioned in the thread you had posted in?

Our QA team has started to investigate this behavior with the RealTek drivers and have asked me to gather some information from users whose Roon stability had been affected by the RealTek driver. If possible, may I kindly ask you to please verify the following information for me:

  • A brief but accurate description of your current.

  • What version of the the RealTek driver that was/is on the affected computer.

  • The motherboard model in the computer (noted in your previous: “Asus ROG Maximus XHero”).

  • The bios version on the affected computer.

I look forward to your feedback! Many thanks!

I have installed Roon on 3 different systems. On the 2 Asus ROG Maximus systems, Roon does not work with the built in audio device. On an older system Asus Sabertooth, Roon System Output consistently works. All of these systems’ Realtek HD Audio device seems to work just fine for everything else on my systems, just not the Roon. And, as I mentioned, Roon works great on my Oppo UDP203 using iOS and/or Android tablet as remote control. The Oppo also shows up as a device or Zone in the Roon interface on all 3 computers so I could use the PC as a remote control.

All computers are Windows 10 64 and always up to date.

Asus ROG Maximus X Hero BIOS 1003 and latest Realtek HD Audio driver Realtek Audio Driver V6.0.1.8273
Asus ROG MAXIMUS VIII BIOS 3703 and latest Realtek HD Audio driver Realtek Audio Driver V6.0.1.8158

Both of these systems’ Realtek HD Audio DO NOT work with the Roon System Output. When I first installed Roon on the Asus ROG Maximuss VIII IMPACT, the System Output worked at first, but after restarting Roon, the System Output was gone.

Asus Sabertooth Z87 - BIOS 1707 (NOT latest version of BIOS) (NOT latest Realtek HD Audio driver) Roon System Output WORKS.
Roon System Output on this older motherboard consistently works! It also use a Realtek HD Audio device. However, this system is in a secondary editing suite where I rarely work. I’m always on the new systems.

Thanks for looking into it. Hope this helps. I love having Roon on my Oppo with album artwork and I’m definitely leaning toward Tidal to replace my Spotify subscription. Nothing against Spotify, I just like having access to high quality and lossless audio. I hope to get it working on my new systems. I don’t dare ask if you could get Roon working on my Amazon Echo. That would be a nice bonus.

Thank you for the follow up and taking the the time to answer my questions, @QB_White. The feedback is appreciated!

Is there any way you can verify the RealTek driver version being used with the Sabertooth 787? I am certain the team is going to want to have that information being as that system is functioning as expected.


The Control Panel on my older, Asus Sabertooth Z87 says the driver version for the Realtek HD Audio is

1 Like

Hi @QB_White — Thank you again for your continued feedback and more importantly, thank you for your patience while our tech team has been testing this behavior in our QA lab.

Moving forward, our techs have informed me that the RealTek drivers that come with certain classes of ASUS motherboards can be problematic and the DEVS feel that these drivers are not necessary to use the software and recommend removing the drivers from your machines that are exhibiting this behavior.


Although Roon seems to work with some of my computers’ built in audio devices, it would not recognize the Realtek HD Audio device on my newest and most choice system. Therefore, I purchased the Audio Quest Dragonfly Black and installed it as a USB audio output device with stereo mini jack to stereo RCA to my powered desktop speakers. The new Dragonfly DAC device is recognized by Roon and sounds excellent. I now have the ability to use Roon while working at my computer system in addition to our Oppo UDP 203 in the Home Theater here at our studio. Cool!

Also tested the Dragonfly Black with Premiere Pro, video games and other multimedia programs on my system. Everything sounds good! Next, I will experiment with Tidal HiFi.

New question: We already have an Amazon Echo that works with Spotify, but I plan to cancel our Spotify subscription and divert those funds to Roon/Tidal subscription. Is it possible to use Roon/Tidal with the Echo? If not, are there any speaker devices like Amazon Echo that will work with Roon/Tidal? Any recommendations?

Thanks for touching base with me @QB_White, glad to hear you are enjoying the Dragonfly Black, I have the RED and I love it.

In regard to your question about the ECHO, here is a statement from our COO Danny about the device (in regard to Roon):

This project is in the back burner… It never worked well… Alexa seems to fail badly when music is playing, and the fact that Roon sounds like Room makes it even worse.

We could release it, but it’d be a very poor product. Additionally, no one on our team would want to live with it, so it would slowly wither and just be a sore spot for Roon members who would expect a high quality product.

The idea is great, but the implementation isn’t there… :frowning:
We will revisit with future software updates

However, one of our moderators has shared how he uses Roon + Alexa here:

Since it is its own bluetooth speaker I can even stream Roon to it
from my tablet or phone. A perfect in kitchen product. And really
unexpected since, I originally acquired it with the use case of
replacing my pen and paper grocery list with a scenario of just being
able to say “Add broccoli to my shopping list” and have it added to the
list on my phone automatically.


Hi, sorry for my poor english, it’s not my first language.

I have same problem on my portable a ROG Strix GL703GM. First time installation work perfectly on every output (system, airplay, …). Next day when i restard the pc … “output system” as disapear … without any change or new install.
When i try to re-install Roon, the “System output” appear shortly in the audio setup panel. If i try to active it, the process fail after few seconds without any message and the “System output” option disapear from the panel :frowning:

So now the good news, after few hours of searching, i find that discussion … so i uninstall Realtek driver and miracle, everything goes well :slight_smile: And i’m now able to activate Wasapi output that option was never available before the uninstall.