Audeze Mobius Headphone USB-C Not working

@support I just got a pair of Audeze Mobius headphones. I connected them to USB-C, enabled the audio device, selected the new device and tried to play a playlist. It just skipped through all the songs. I was able to play through the headphones connected to USB-C using Tidal and Foobar2000. I then connected them up with Bluetooth and I was able to get them to work. All my other devices work fine.

Can you offer any help on the USB-C setup?

I’m running Roon Version 1.5 (build 354) stable (64bit) on an AMD Ryzen 7 1700X with 12GB of RAM. My music is on on a NAS connected via a gigabit switch.

What operating system on the core machine?

I’m sorry it is Windows 10 Home version 1803 build 17134.286

OK you should be able to go in the settings and override the driver settings. I am away from mine so can’t talk you through it but if you check the setup page out you should see how to do it.

I tried all the basic Roon Audio settings and still nothing out of the Headphones when connected using USB-C. I also tried some different settings under advanced with no effect.
The default settings are:

does Roon think they are a multi channel device or a 2 channel device? Set the multii channel playback to downmix to 2 channels and see if that helps. Or set the Windows driver to e stereo and not multichannel. the goal is to try and get them to work, then, see if we can get multi channel functional

@Brian_Johnston On Windows the best way to use Mobius with Roon when connected using USB is using WASAPI drivers and in 2ch (48kHz) mode if you want 3D/room emulation/head-tracking and in Hi-res (96kHz) mode if you do not want room emulation.

Currently 8ch mode does not work through WASPI and ASIO is not supported. This is true with all players and Mobius, not just Roon.

Whey you use Tidal or Foobar, you were likely using Windows DS drivers, which will work fine.

(Edit 2) To change modes, press and hold the Microphone volume wheel. Once the voice cue confirms it is in the mode you want, either relaunch Roon or hit refresh on the Audio settings in Roon.

(Edit 1) Adding couple of screen-shots. It is also a good idea to enable DSP/resampling


@KMan. Thanks for the tips. Switching to either 2Ch or HiRes did the trick I missed that part in the Mobius manual. The headphones are working great now!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.