Audio Analysis preventing NAS or Roon access

Roon Core Machine

Roon Nucleus+ (basic)
NAS Synology DS1513+/DX513 both 5 x 4TB WD Red in RAID 6 configuration

Networking Gear & Setup Details

Ethernet Linksys AC3000 Mesh Router.
Uptone EtherREGEN

Connected Audio Devices

Number of Tracks in Library

238,500 tracks most 44.1/16 many in higher res 96 & 192/24 approx. 12TB.

Description of Issue

Think I screwed up: just had to re-build my Roon library after changing NAS folder locations and having connection/access issues. Cleared caches and updated Nucleus and reset library path. Took 5 days to complete.

Roon was still running Audio Analysis in background and going to take forever so increased the analysis speed to a much higher level.

Now my NAS has been running continuously with lots of flashing across all bays for over 3 days.

I’m unable to access either the NAS via Synology assistant or via network. The NAS “diskstation” seems to keep appearing/disappearing on network via my laptop Mac Finder and attempts at connecting via ethernet or wifi are failing.

The “Nucleus+” is showing up connected to network via ethernet based on Mac Finder and Linksys app but Roon app is also failing to connect to the Nucleus+ via laptop or iPad.

What’s my next steps? Is this to be expected given the size of my library and allow Audio Analysis to keep running however long it may take?

The only other option I can think of is manually shutting down the Synology NAS using the DS1513+ front button.

If I do take this step anything else I should do before restarting NAS to avoid Roon just restarting the Audio Analysis or even worse screwing up my library?

Should I also shut down and restart Nucleus+?

Suggestions appreciated before I possibly screw up further. Thanks

If the settings are still possible in remote access (computer, mobile phone, tablet), then the audio analysis would again be off or set to very slow. With this large library, fast audio analysis is a handicap.


How do you do this?

I’m asking as it important that does not see a two paths to your files, otherwise it thinks the files are new (in addition to the ones it already knows about) and starts performing identification and audio analysis from scratch.

The process I advise to follow is:
Double check you have at least a couple of recent Roon DB backups (just in case).
Then in Roon’s Settings → Storage:

  • Disable the current watched folder
  • Edit the current watched folders path to the new location.
  • Enable the current watched folder

Alternatively delete current Watched folder and create a new one.

I have a similar number of tracks in my library to you on a QNAP NAS, when I changed the path (last year) Roon only re-scanned the file system it took a while but just a few hours not days. Once it was completed, I had the same number of tracks and all the import dates and other metric were unchanged as expected.

Thank you for response Carl but I had already dealt with rebuilding the library, that is not the problem. Issue is I cannot access Roon (including the settings) nor can I access my NAS to check whether it’s making any progress and all is good.

So my question really is should I be expecting it to take several days for the Audio Analysis complete the task and is it normal not to be able to access Roon or the NAS while this is happening?

Or does it sound like I have a problem and I need to take some action to somehow stop whatever is going on?

But in answer to your response, for various reasons decided to re-build library from scratch so I deleted the old library path and cleaned the Nucleus+ caches when I changed NAS path location. I did make sure the old path was gone and did check to make sure the new back-up location worked.

Thanks for the clarification, I understand now you are rebuilding the Roon DB starting with no tracks known to Roon.

When you say “cleaned the Nucleus+ caches”, how did you do this?
I’m trying to confirm if you instructed the Nucleus (via the admin web interface) to install a clean database (which would be best when starting from scratch) or used Roon’s Setting → Library → Library Maintenance → Clear up library (which just removes deleted file references from the DB).

If the later, I’m concerned some relics may still be in the DB and cause issues … but this is just speculation on my part … Roon @support would have to confirm.

When I first setup Roon iirc it took about 5 days or so for it to complete the Audio Analysis, during this time I was still able to play tracks though search etc. was a little sluggish.

I could be that something has hung, I suggest try rebooting the Nucleus to recover and see what happens when it comes backup.

Thanks again Carl. Since it’s only been 3 days since I started the faster Audio Analysis, so it could just be taking a long time given the number and size of my tracks (in addition to many high-res they are also mostly jazz rather than shorter pop songs).

But since I cannot access Roon or NAS have no idea if it’s making progress or in a loop. If the inability to access is to be expected at the higher Audio Analysis speed as it seems Uwe is suggesting, I’m afraid that shutting down mid-stream could corrupt the library I spent days re-building (I have no way of knowing if it completed a back-up since the re-build).

But since I cannot control Nucleus via app presumably you’re suggesting rebooting by using button in back?

BTW - pretty sure I had deleted the old library because it showed 0 tracks and then I also used the Maintenance function as well to clean up the caches. Before I stupidly upped the Audio Analysis speed everything seemed to be in order.

Hmmm…if you can’t access your Synology (e.g. the DSM interface) what makes you think that your Nucleus+ can? I suspect something has gone horribly wrong with your network or your NAS. I would not assume that any progress is being made on analysis.

1 Like

Still not sure what was preventing NAS/Roon access but after several attempts I was finally able to connect my laptop via ethernet and open both Synology and Roon.

Discovered Audio Analysis function was indeed making (very slow) progress, and after resetting the speed to “Throttle” was able to play some tracks through Nucleus+ server.

However, turned out I had wrongly assumed the spinning wheel in upper right hand corner seen on initial Roon start window was due to the Audio Analysis still working in the background. But when I clicked on the spinning wheel (which I did not realize was possible – sorry might be intuitive to those more used to playing with computer software but not this boomer) turned out that there was a Metadata issue which had paused building my library due to a network connection problem. I stumbled upon this realization when Roon failed to process a few additional albums I had added to the NAS folder and also was no longer displaying progress for Audio Analysis,

Of course it wasn’t clear how to resolve the problem so finally gave in to shut down and restart the Nucleus+. After restart and reopening Roon got a message that connection was being delayed because apparently a prior Nucleus update had not fully finished installation (possibly required a restart??) but whatever the cause, after Roon re-connected became clear that the Nucleus had not finished initial Library processing, still missing several hundred tracks and even more metadata from the NAS files.

Finally after another hour or so the spinning wheel disappeared and so now have 239,044 tracks. (There’s still a spinning wheel in Settings > Library next to Audio Analysis but that’s slowly making progress in background.)

Bottom line: all appears to be good and looks like back-up is functioning.

Thank you to all who responded.


Excellent news. I’ll mark this topic as solved and it will close in a couple of days.
However, if you have further issue with this just post and I’ll (or another mod) can reopen and merge.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.