Audio Analysis stuck; need help identifying corrupt files

Roon Core Machine

Dell Precision 5820 Tower
Intel(R) Xeon(R) W-2225 CPU @ 4.10GHz 4.10 GHz
64.0 GB (63.7 GB usable)

Networking Gear & Setup Details

No wifi; hard-wired Ethernet

Connected Audio Devices

Focusrite Scarlett Solo 3rd Gen (USB)
Sonos Connect (Ethernet)
Music stored on Drobo 5D (32TB), connected via USB3.0

Number of Tracks in Library

~500,000 tracks

Description of Issue

Audio Analysis is stuck: 5 / 48534
It has run on the rest of the library
Library is stored in ~80 subfolders which are all located on the same Drobo partition

Just got this computer and rebuilt the Roon library from scratch.
First-time seeker of Roon support; thanks in advance for your patience, and assistance :slight_smile:

Hi @Kevin_Wyatt an welcome to the Roon forums. The Room log files are often helpful in this situation. On my Linux box these live under /var/roon/RoonServer/Logs, it won’t be the same under Windows. BTW what format are your audio files?

Good luck

Have you tried rebooting everything including the network. You may not be connected to the Roon cloud properly

A corrupt file shouldn’t stop analysis, it should skip and carry on

It should but…

Thank you for the prompt response.

I have uploaded the compressed Logs folder via Roon Log Uploader.

My files are in multiple formats - mostly mp3 but also some AIF and WAV (intentional), and possibly some FLAC & m4a (unintentional, I’ll run a search now to see if any remain)

Hi @Mike_O_Neill

I have rebooted the entire network. When I restarted Roon, it re-scanned the entire library, which took a few hours. I have enabled all sub-folders and the current “stuck analysis” count is 1615 / 48530

But you say 500,000 tracks , why 48k not 500k

The audio analysis of 500k tracks will take a while it is a massive library

On your Core PC do you have an SSD C drive or a spinning disc ? I assume it’s Windows 10 or 11 ?

This is sounding Roon db related , once imported there is no reason for Roon to re-import files. It will carry on analysing in the background

In settings > storage you should see the number of files imported

Back online; hope y’all are enjoying the year-end festivities.

So, I too was curious about the track count discrepancies and did some fiddling. Here is what I am observing:

  1. As previously noted, I store my files in ~80 sub-folders that share the same parent folder & drive (easier to manage the collection this way). I individually added each folder in Roon Storage setting.

  2. Before enabling/disabling a folder, I disable Audio Analysis. First, I started by disabling all 80 folders. Result was expected: when I enabled Audio Analysis, it did not get stuck (as presumably, zero files were visible to it).

  3. Next, I enabled the first folder in my (non-alphabetized) folder list: “Indie Playlist VIII”. Result: in Storage setting, the folder displays the standard message “Watching for new files in real time; 3,684 tracks imported.” So far, so good.

  4. Next, I enabled the next folder in the list - “Indie Playlist 48” - with the same result.

  5. Next, I enabled the third folder in the list: “Indie Playlist V”. This is my first “problem folder”: when I enable Audio Analysis, it gets stuck (at the moment, displays “analyzing 51 / 76”

  6. I disabled Indie Playlist V, and worked my way down the list (first 12 or so), enabling one folder at a time. Some folders are fine; others also get stuck in Audio Analysis, with different values per folder. I can audit all 80 if this is helpful.

When a folder gets “stuck” it will do so on the same track is my guess. If you look in the log files you can locate the individual bad tracks.

Thanks @killdozer I assume this as well.

How does one identify a corrupt/bad track via the log files?

How handy are you on a command line? I don’t have a Windows Roon instance to hand right now so help would be limited. You need to open the log file in a text editor and do a little scrolling/detective work. If memory serves you can see each track analysed and identify any with issues by file path