Audio clicks using Teac NT-505 as decoder+renderer

Core Machine (Operating system/System info/Roon build number)

Mac Book Pro 32GB Vega 20 late 2018 + RazerCore X thunderbolt 3 + Nvidia GTX1080Ti
MacOS (latest) + Windows10 Pro (bootcamp)
Roon latest release

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Gigabit ethernet through CallDigit TS3 Plus thunderbolt 3 dock

Audio Devices (Specify connection type - USB/HDMI/ect.)

TEAC NT-505 (latest 1.21 firmware) gigabit network connected

Description Of Issue

Perceptible random (very low level) clicks on all Tidal MQA tracks when setting the Teac NT-505 as Decoder+Renderer.
Everything is fine when setting the NT-505 as Renderer and Roon as Decoder.
All tests done with Roon on MacOS and Roon on Windows10 (bootcamp).
Lumin iOS app doesn’t produce any clicks.

Have you updated both the DAC firmware and network firmware?

Was going to ask the same question, Henry… The latest NETWORK firmware is 11.1e. Have you run that (via the HRStreamer app) as well?

Also, just to clarify, is it happening ONLY with MQA tracks?

Hi @gabriele_gelfo,

As suggested above, Definitely make sure that your firmware is fully up to date here.

If everything is updated and you’re still having issues can you share a screenshot of your Signal Path in Roon when playing MQA content?

NT-505 supports MQA Renderer in Roon Ready mode, so it’d be perfectly fine for you to set it as Renderer Only. Whether the MQA Core decoding is done in Roon Core or in NT-505 does not affect the decoded output digitally at all.

If you really want to experiment with “Decoder+Renderer” further, try using Lumin app to disable Lumin Streaming (AirPlay) and Spotify Connect.

Everything is updated, network and hardware firmware.
Unfortunately I heard some clicks also on other tracks (for example Diana Krall) using Roon as Decoder and the Teac NT505 as renderer.
I also tested using the Teac connected through the usb port (no MQA render support) and Roon as decoder+renderer. I heard the same clicks in the exact time position.
I don’t know if it’s a Roon or Teac issue. I will check with another dac the same Diana Krall track.


If not done so already, you can turn on the clipping indicator by following the guide ‘DSP Engine: Headroom Management’ and keep an eye on the signal path light. Maybe the clicks are just digital clipping.

the issue is related to the audio track available on Tidal. I did a double check on two different systems.
I thought there was a problem with Roon or my dac. Unfortunately some Tidal tracks have issues.


Hello @gabriele_gelfo,

We are able to reproduce some issues during playback with the TEAC NT-505. I will be reaching out to TEAC today for further guidance.

In the meantime, could you report how you have the NT-505 connected to your other audio devices? Are you using the headphone amplifier, the RCA outputs, or the XLR outputs on the rear of the device? What do you have the volume control type set to?

When you set the volume control to “variable” and set the volume to ‘90’, do you still hear the audio clicks and pops?


this is my config:
Teac NT505–>XLR out (hot2)–> Vovox cable shielded (5 meters) --> Focal Solo Be 6
1Gb ethernet cable
Laptop Mac Book Pro late 2018 32GB Vega 20 with MacOS and Windows 10 Pro (bootcamp)
Roon is installed on both os.
The laptop is also connected to the dac with an Audioquest Cinnamon (1,5 meters) cable.

I found that some tracks on Tidal have audible clicks (it’s not mic or instrument noise)
But I found also that Roon produces same digital clicks also on tracks that through Lumin are clean.

I have to investigate what is the cause.
It could be an electrical interference on dac? Probably it happens before the analog circuit because the xlr should avoid electrical interferences.


I have experienced the random clicking with the tidal lang lang mqa but not quboz lang lang same album… did we find a solution? This on nt-505

Use Lumin app to disable Lumin Streaming (AirPlay) and Spotify Connect.

In Roon, set MQA Capabilities for NT-505 to be “Renderer Only”.

appreciate a solution but is this a teac issue or roon issue or tidal mqa issue? i shouldn’t have to disable feature to use a feature. sounds like software bug that needs to be addressed. has anyone narrowed it down?

thanks for work around for now and i’ll try

I must admit, as a Roon user the first thing I did was disable the protocols I had no immediate intention of using. I did let the Teac do the full MQA processing but after I had used Roon to do DSP and adjust headroom I found the Teac no longer saw a bit perfect signal so did not process the MQA. So I set its capabilities to renderer only in Roon which then does a first unfold, applies my DSP then passes to the Teac for rendering at the appropriate sample rate. This works really well and should really be the default way to use the Teac with Roon and MQA.

That is another Interesting perspective and thanks for sharing. Though in theory one protocol should not interfere with another. Sounds like a software bug that needs to be resolved.

If one is not going to use the other protocols ever then that’s a solution. Though it doesn’t solve the underlining issue if one did want to use those protocols.

1 Like

Yet the ongoing debate is that by letting first unfold in software, we miss out on the full MQA decoder capabilities of the unit.
I face the same dilemma in the office listening via Pre Box S2 Digital when I want to use the Audeze Presets DSP (which makes the signal not bit perfect)

A full MQA decode is a full decode regardless of if it is done in one place or split between two. To be clear my example allows full decoding as well as DSP which should be a superior result.

No, you do not miss anything. MQA Core decoding on Roon Core or a DAC is 100% the same. NT-505 also accepts MQA Core signal from Roon Core and does MQA rendering correctly.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.