Audio device refused to switch input to Roon stream

I get this error on my iPhone that is acting as my control for my Roon system 50% of the time I turn on Roon or my Ayon S-10 Streaming DAC. When this happens, my DAC will not play Roon selections even though I can see the selected album on its display. A series of turning the DAC on and off or regrouping my multiple players (one is a Mac laptop and the other is a Dell laptop and they NEVER have this problem) - I haven’t been able to find any consistent process to solve the problem, or prevent it from happening, but after 2-3 of these gyrations, Roon and the DAC connect and I have great Roon operation through this high end DAC all day/evening until I turn everything off and bring it up in the morning and then I go through the same annoying process again. Anyone else having problems with Roon not connecting to their hi end DAC?
Tech info: all of my devices are wired. My Ayon S-10 DAC displays the Roon album selected but will not output audio when this problem occurs. I NEVER have this problem the the two laptops that play Roon (the Dell laptop also acts as my Roon core. The longest cable length between units is 50’. I have a Regen switch between the two laptops (plugged into the A side) and the Ayon plugged into the single B side. The DAC will always play CDs or files from USB storage even when Roon won’t play. So to me, it clearly means there is some problem between Roon and my Ayon S-10 which is Roon Ready from the factory and plays it perfectly but only when they “catch” each other just right. This is why old dudes like me never wanted to get involved in streaming! :worried::face_with_raised_eyebrow::rage::face_with_symbols_over_mouth:

Yes, I’ve had that issue, one time only, with the RAAT Ethernet connection to my DAC. Hit play a second time and it worked. I have seen another post on the subject so it seems at least 3 of us have encountered the issue. So far it has not been a disruptive issue, single occurrence, has not been repeated yet.

I have same thing on my moon dac streamer. Cannot get it fixed… no support at all from Roon and help from Roon here I see as well… are even supporting you or was it solved and how?

Is this a constant issue or does it only happen the first time you try to play music to the device after it is powered up? For me, the only time the issue occurred was the first time Roon tried to play to the device after the device was powered up. If I hit play a second time it worked.

Is the firmware on your Dac current? I found a firmware update for my device. Don’t know if the device firmware update resolved the issue but it has not reoccurred since then and it wasn’t a constant problem to begin with.

How long do you wait before you try to play to your DAC after turning it on?

While the DAC and its conventional in/outputs are possibly ready as soon as the lights turn on, USB and network functionality is mostly added by an add-on module from a third-party supplier. These add-on boards are controlled by micro-controllers (miniature specialized PC) and they usually take considerably more time to boot up their microcode (OS, drivers and software) and initialize their hardware. Also sometimes you can find power-save/standby options in the device menu that control in the end if the add-on board turns off with the device or stays active (at the cost of higher standby power consumption) for convenience.

A post was merged into an existing topic: Problems with playing on my Moon 280D “Audio Device Refused to switch input to Roon”

We have different brand Roon Ready devices, with similar issues, but there seems to be differences in severity. Mine was a minor inconvenience.

The exaSound s88 has a delay built in to the startup sequence, identified in the doc. The power light comes on but the display stays dark for 30 to 40 seconds, then the screen lights up coinciding with Roon seeing it on the network.

Looking at device info, the RAAT SDK version is at 1.1.36 after the latest firmware update. Did not check that prior to the update and don’t know if that may have changed.

I have other Roon Ready devices that list 1.1.38. I’ve not had the issue on the other devices but they are Elac Z3’s that are always on.

Yes. I also have the issue with my Moon 390 DAC/ preamp.

It used to work fine earlier . Some recent update / firmware / Roon has started causing this issue. I have done Hard reset ( remove power chords) etc but the problem repeats


Check out this thread

All is explained. But not yet solved.

I have again done a hardware reset and it has worked. Guess after any update one needs to unplug the power chord for a good few minutes and power back on

1 Like

After 3 weeks with the firmware upgrade, I have only had the “will not switch to Roon”
Issue 3 times. Still 3 too many, but a big improvement. And to “resync” my Ayon S10Ii DAC
with Roon, I just do a front panel reset on the DAC and they connect and I’m streaming must c!
So not perfect, but a BIG improvement!!