Audio devices not selectable and/or play pause buttons greyed out

Core Machine

Nucleus Model B with 2 TB internal SSD

Network Details

Roon attached to AmpliHD router mesh point.

Audio Devices

I am having trouble across a variety of devices. They all show up as enabled on the Audio setup page.

PS Audio Srpout connect via USB to Mac running OS 11.4
HiFiBerry Raspberry Pi AMP connected to network via Raspberry Pi WiFI

Library Size

1309 albums

Description of Issue

This is a replacement Nucleus I set up yesterday. Reinstalled from back up and everything was working properly. Today I have seen the following issues:

Sprout - sometimes does not show in as selectable. When it is selectable and I play music the pause button is greyed out. The pause all button within the device selector in the lower right is also greyed out.on my Mac. On my iPad the pause all button is displayed but the start/;pause for the device in the middle is greyed out. The info along the bottom left also says nothing is playing even when music is streaming

One of two Ropieee devices connected via wifi does not show up. one has been intermittent
One additional Ropiee device connected to an AmplifHI by ethernet and a device via USB is not showing up.

I have tried reinstalling the operating system and restarting the Roon Server software via the web interface. The issue shows up across my computer as well as iPad and iPhone

Note: Running Roon 1.8 Build 795

@support I have noticed the backups are also failing. Perhaps related to the same issues? Looking at the folders I have selected for the backups to go to, I notice they are showing being revised but Roon app shows the backup failed in red font and says “Error backing up database”. When I look in the backup folder I notice it only has one folder with the name xx where the successful backups have many folders with names of a number and a letter

Hey @Jay_Frankel,

I’m so sorry for the delay in replying :pleading_face: - today is our first day back after Memorial Day weekend and we’re not yet all caught up.

To trace the issue of this problem, could you pelase install Roon fresh on your Core machine? You can use these instructions to do so:

  • Stop RoonServer from running in Nucleus’s WebUI
  • Navigate to your Nucleus’ Database Location
  • Find the folder that says “RoonServer”
  • Rename the “RoonServer” folder to “RoonServer_old”
  • Restart the RoonServer in the WebUI to generate a new Database
  • On the Roon Remotes, press “Use another Core” and connect to the new database

For now, please do not restore your database. We’d love to establish if Roon works with a fresh one.

Thank you so much :pray:

Hi @beka , Hope you had a better holiday weekend than me, my Roon was down and our weather was terrible here in CT. Very untimely to have the issue right before a long weekend.

The good new is everything seems to be working after letting the Roon create a new database. (I have not tried a back up).

What are the next steps as far as using a back up. Will the last back up I have potentially be corrupted? What is the cause of this issue?

Looking forward to getting my Roon operational again. I have only had it since March and this is the third issue with two hardware failures. But I do love the system and I am happy to be back in action.

Thank you

Hey @Jay_Frankel,

That doesn’t sound like a great weekend, you are right (unless maybe a hot drink and a movie might have saved it :blush:).

Thanks for trying the proposed solution. It’s great news that there’s nothing wrong with Roon in your setup. Now it would be a great time to try restoring your backup (if you have more than one, feel free to try any of them out):

If everything loads properly, you’ll be good to go.

I’m incredibly impressed by your loyalty :heart: . Thanks for working with us through not one, but two hardware failures… :pray: